summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKajzer <kajzersoze72@gmail.com>2018-05-04 12:59:23 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-05-04 23:05:07 +0200
commit6d597a32e22e77dc620678702aad9c14e44d2978 (patch)
tree8533a33f30710f8f8b0de086b994b140dd5f69d2 /x11-misc/polybar/polybar-9999.ebuild
parentdev-lang/php: Fix building with freetype 2.9.1 by using pkgconfig (diff)
downloadgentoo-6d597a32e22e77dc620678702aad9c14e44d2978.tar.gz
gentoo-6d597a32e22e77dc620678702aad9c14e44d2978.tar.bz2
gentoo-6d597a32e22e77dc620678702aad9c14e44d2978.zip
x11-misc/polybar: new package.
Polybar is a fast and easy-to-use tool for creating status bars. Closes: https://github.com/gentoo/gentoo/pull/8244 Closes: https://bugs.gentoo.org/643286
Diffstat (limited to 'x11-misc/polybar/polybar-9999.ebuild')
-rw-r--r--x11-misc/polybar/polybar-9999.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/polybar/polybar-9999.ebuild b/x11-misc/polybar/polybar-9999.ebuild
new file mode 100644
index 000000000000..b21888340078
--- /dev/null
+++ b/x11-misc/polybar/polybar-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-utils git-r3 python-single-r1
+
+DESCRIPTION="A fast and easy-to-use tool for creating status bars"
+HOMEPAGE="https://github.com/jaagr/polybar"
+EGIT_REPO_URI="https://github.com/jaagr/${PN}.git"
+EGIT_CLONE_TYPE="shallow"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+
+IUSE="alsa curl i3wm ipc mpd network pulseaudio"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ x11-base/xcb-proto
+ x11-libs/libxcb
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-image
+ alsa? ( media-libs/alsa-lib )
+ curl? ( net-misc/curl )
+ i3wm? ( dev-libs/jsoncpp )
+ mpd? ( media-libs/libmpdclient )
+ network? ( net-wireless/wireless-tools )
+ pulseaudio? ( media-sound/pulseaudio )
+"
+
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_ALSA="$(usex alsa)"
+ -DENABLE_CURL="$(usex curl)"
+ -DENABLE_I3="$(usex i3wm)"
+ -DBUILD_IPC_MSG="$(usex ipc)"
+ -DENABLE_MPD="$(usex mpd)"
+ -DENABLE_NETWORK="$(usex network)"
+ -DENABLE_PULSEAUDIO="$(usex pulseaudio)"
+ )
+ cmake-utils_src_configure
+}