summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/qcomicbook
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/qcomicbook')
-rw-r--r--x11-misc/qcomicbook/Manifest1
-rw-r--r--x11-misc/qcomicbook/metadata.xml6
-rw-r--r--x11-misc/qcomicbook/qcomicbook-0.9.0-r1.ebuild55
3 files changed, 62 insertions, 0 deletions
diff --git a/x11-misc/qcomicbook/Manifest b/x11-misc/qcomicbook/Manifest
new file mode 100644
index 000000000000..97abe71d4927
--- /dev/null
+++ b/x11-misc/qcomicbook/Manifest
@@ -0,0 +1 @@
+DIST qcomicbook-0.9.0.tar.gz 738514 SHA256 8e36f94d7b55798258b6df085324da150b0983020853eb270992157e9692abcb SHA512 e3df724d851822a1d7e72fd6a9fc3b14d5d406d97e0098ddd07a6329a3fe98cc8aa5e77d071f98399d60f231bd0d6dd17ab995aa5e784171aa69fa3fd1ce861b WHIRLPOOL 93234e38c3a589139e305497aaef6d70ffdd09c9fd7fa71e39287dbd3e37dd3a7831b549bf53a72bb3193ca29fd353c282af1a80554de838cbd26265bd23b578
diff --git a/x11-misc/qcomicbook/metadata.xml b/x11-misc/qcomicbook/metadata.xml
new file mode 100644
index 000000000000..baccd90af55a
--- /dev/null
+++ b/x11-misc/qcomicbook/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <herd>qt</herd>
+</pkgmetadata>
diff --git a/x11-misc/qcomicbook/qcomicbook-0.9.0-r1.ebuild b/x11-misc/qcomicbook/qcomicbook-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..3433048e7ddc
--- /dev/null
+++ b/x11-misc/qcomicbook/qcomicbook-0.9.0-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+CMAKE_IN_SOURCE_BUILD=1
+PLOCALES="cs_CZ de_DE es_ES fi_FI fr_CA fr_FR it_IT ko_KR nl_NL pl_PL pt_BR ru_RU uk_UA zh_CN"
+inherit cmake-utils flag-o-matic l10n
+
+DESCRIPTION="A viewer for comic book archives containing jpeg/png images"
+HOMEPAGE="http://qcomicbook.org/"
+SRC_URI="http://qcomicbook.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="debug"
+
+DEPEND="dev-qt/qtgui:4
+ app-text/poppler[qt4]"
+RDEPEND="${DEPEND}"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+src_prepare() {
+ rm_loc() {
+ rm "i18n/${PN}_${1}.ts" || die "removing ${1} locale failed"
+ }
+ rm "i18n/${PN}_en_EN.ts" || die 'removing redundant english locale failed'
+ l10n_find_plocales_changes "i18n" "${PN}_" ".ts"
+ l10n_for_each_disabled_locale_do rm_loc
+
+ # fix desktop file
+ sed -i \
+ -e '/^Encoding/d' \
+ -e '/^Icon/s/.png//' \
+ -e '/^Categories/s/Application;//' \
+ "data/${PN}.desktop" || die 'sed on desktop file failed'
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ use !debug && append-cppflags -DQT_NO_DEBUG_OUTPUT
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ elog "For using QComicBook with compressed archives you may want to install:"
+ elog " app-arch/p7zip"
+ elog " app-arch/unace"
+ elog " app-arch/unrar or app-arch/rar"
+ elog " app-arch/unzip"
+}