summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-11-17 06:43:43 +0300
committerMichael Palimaka <kensington@gentoo.org>2016-11-17 22:51:30 +1100
commit02f6df9acbf526316885f5325a93ceeb0d3ad85d (patch)
tree50081a40790391252d510315ee20480935d3d203 /x11-misc/qt5ct
parentkde-plasma/plasma-workspace: Drop old (diff)
downloadgentoo-02f6df9acbf526316885f5325a93ceeb0d3ad85d.tar.gz
gentoo-02f6df9acbf526316885f5325a93ceeb0d3ad85d.tar.bz2
gentoo-02f6df9acbf526316885f5325a93ceeb0d3ad85d.zip
x11-misc/qt5ct: make system tray support optional
Gentoo-Bug: https://bugs.gentoo.org/599950 Closes: https://github.com/gentoo/gentoo/pull/2855 Package-Manager: portage-2.3.2
Diffstat (limited to 'x11-misc/qt5ct')
-rw-r--r--x11-misc/qt5ct/metadata.xml3
-rw-r--r--x11-misc/qt5ct/qt5ct-0.27-r1.ebuild50
2 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/qt5ct/metadata.xml b/x11-misc/qt5ct/metadata.xml
index 74362b492c50..2e9a34141459 100644
--- a/x11-misc/qt5ct/metadata.xml
+++ b/x11-misc/qt5ct/metadata.xml
@@ -13,6 +13,9 @@
This program allows users to configure Qt5 settings (theme, font,
icons, etc.) under DE/WM without Qt5 integration.
</longdescription>
+ <use>
+ <flag name="systray">Enable system tray support</flag>
+ </use>
<upstream>
<remote-id type="sourceforge">qt5ct</remote-id>
</upstream>
diff --git a/x11-misc/qt5ct/qt5ct-0.27-r1.ebuild b/x11-misc/qt5ct/qt5ct-0.27-r1.ebuild
new file mode 100644
index 000000000000..8c8cc16ec066
--- /dev/null
+++ b/x11-misc/qt5ct/qt5ct-0.27-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Qt5 configuration tool, similar to qtconfig for Qt4"
+HOMEPAGE="https://sourceforge.net/projects/qt5ct/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+systray"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5=
+ dev-qt/qtwidgets:5
+ systray? ( dev-qt/qtgui:5[dbus] )
+"
+DEPEND="${RDEPEND}
+ dev-qt/linguist-tools:5
+"
+
+src_configure() {
+ eqmake5 DEFINES="$(usex systray '' QT_NO_SYSTEMTRAYICON)" ${PN}.pro
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ echo 'QT_QPA_PLATFORMTHEME=qt5ct' > "${T}"/98${PN} || die
+ doenvd "${T}"/98${PN}
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ ewarn "qt5ct configuration won't be applied to the currently running sessions."
+ ewarn "Please relogin."
+ fi
+ if ! has_version 'dev-qt/qtsvg:5'; then
+ echo
+ elog "For SVG icon themes, please install 'dev-qt/qtsvg:5'."
+ echo
+ fi
+}