summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2017-11-29 00:30:00 +0000
committerDenis Dupeyron <calchan@gentoo.org>2017-11-29 00:30:18 +0000
commit830468c4edd9ab377c33836c4d694acc8c68e600 (patch)
tree8cd9e65016856e3c59e06e2e5550d637d04c9740 /x11-misc/rodent/rodent-5.3.16.3-r1.ebuild
parentmedia-gfx/pngquant: Bump to v2.11.4 (diff)
downloadgentoo-830468c4edd9ab377c33836c4d694acc8c68e600.tar.gz
gentoo-830468c4edd9ab377c33836c4d694acc8c68e600.tar.bz2
gentoo-830468c4edd9ab377c33836c4d694acc8c68e600.zip
x11-misc/rodent: migrate to EAPI6
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'x11-misc/rodent/rodent-5.3.16.3-r1.ebuild')
-rw-r--r--x11-misc/rodent/rodent-5.3.16.3-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/rodent/rodent-5.3.16.3-r1.ebuild b/x11-misc/rodent/rodent-5.3.16.3-r1.ebuild
new file mode 100644
index 000000000000..ad96bd85d815
--- /dev/null
+++ b/x11-misc/rodent/rodent-5.3.16.3-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools gnome2-utils xdg-utils
+
+DESCRIPTION="A fast, small and powerful file manager and graphical shell"
+HOMEPAGE="http://xffm.org/"
+SRC_URI="mirror://sourceforge/xffm/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/librfm-5.3.16.3"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog TODO )
+
+src_prepare() {
+ pushd apps/rodent-pkg >/dev/null || die
+ sed -i -e "/^install-data-hook/d" \
+ -e "/rm -f/d" Build/Makefile.am || die
+ eautoreconf
+ popd >/dev/null || die
+ default
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}