summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2022-11-11 15:23:56 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-11-11 15:25:31 +0100
commit327662dcb2dd6690f56655e5f29afcceb36655f9 (patch)
treebea5c17d6464f24c3f1fb91d838e8492696678d0 /x11-misc/rofi-file-browser-extended
parentapp-emacs/exwm: bump to 0.27 (diff)
downloadgentoo-327662dcb2dd6690f56655e5f29afcceb36655f9.tar.gz
gentoo-327662dcb2dd6690f56655e5f29afcceb36655f9.tar.bz2
gentoo-327662dcb2dd6690f56655e5f29afcceb36655f9.zip
x11-misc/rofi-file-browser-extended: fix incompatible-function-pointer-types
Closes: https://bugs.gentoo.org/880985 Signed-off-by: Florian Schmaus <flow@gentoo.org> Upstream: https://github.com/marvinkreis/rofi-file-browser-extended/pull/49
Diffstat (limited to 'x11-misc/rofi-file-browser-extended')
-rw-r--r--x11-misc/rofi-file-browser-extended/files/rofi-file-browser-extended-1.3.1-fix-function-pointer-initialization.patch23
-rw-r--r--x11-misc/rofi-file-browser-extended/rofi-file-browser-extended-1.3.1-r1.ebuild (renamed from x11-misc/rofi-file-browser-extended/rofi-file-browser-extended-1.3.1.ebuild)6
2 files changed, 28 insertions, 1 deletions
diff --git a/x11-misc/rofi-file-browser-extended/files/rofi-file-browser-extended-1.3.1-fix-function-pointer-initialization.patch b/x11-misc/rofi-file-browser-extended/files/rofi-file-browser-extended-1.3.1-fix-function-pointer-initialization.patch
new file mode 100644
index 000000000000..0cfff4286608
--- /dev/null
+++ b/x11-misc/rofi-file-browser-extended/files/rofi-file-browser-extended-1.3.1-fix-function-pointer-initialization.patch
@@ -0,0 +1,23 @@
+From 6f62a2d0784a6937d35ac8f6df2e22c23bbfc8f4 Mon Sep 17 00:00:00 2001
+From: Florian Schmaus <flo@geekplace.eu>
+Date: Fri, 11 Nov 2022 15:03:32 +0100
+Subject: [PATCH] Fix function pointer initialization
+
+Fix
+
+src/filebrowser.c:380:27: warning: incompatible function pointer types initializing '_mode_get_icon' (aka 'struct _cairo_surface *(*)(const struct rofi_mode *, unsigned int, unsigned int)') with an expression of type 'cairo_surface_t *(const Mode *, unsigned int, int)' (aka 'struct _cairo_surface *(const struct rofi_mode *, unsigned int, int)') [-Wincompatible-function-pointer-types]
+ ._get_icon = file_browser_get_icon,
+ ^~~~~~~~~~~~~~~~~~~~~
+
+See also https://bugs.gentoo.org/880985
+--- a/src/filebrowser.c
++++ b/src/filebrowser.c
+@@ -263,7 +263,7 @@ static char *file_browser_get_display_value ( const Mode *sw, unsigned int selec
+ }
+ }
+
+-static cairo_surface_t *file_browser_get_icon ( const Mode *sw, unsigned int selected_line, int height )
++static cairo_surface_t *file_browser_get_icon ( const Mode *sw, unsigned int selected_line, unsigned int height )
+ {
+ FileBrowserModePrivateData *pd = ( FileBrowserModePrivateData * ) mode_get_private_data ( sw );
+ FileBrowserFileData *fd = &pd->file_data;
diff --git a/x11-misc/rofi-file-browser-extended/rofi-file-browser-extended-1.3.1.ebuild b/x11-misc/rofi-file-browser-extended/rofi-file-browser-extended-1.3.1-r1.ebuild
index 2be17da588a0..a3fe3b3b176b 100644
--- a/x11-misc/rofi-file-browser-extended/rofi-file-browser-extended-1.3.1.ebuild
+++ b/x11-misc/rofi-file-browser-extended/rofi-file-browser-extended-1.3.1-r1.ebuild
@@ -30,10 +30,14 @@ DEPEND="
"
RDEPEND="${COMMON_DEPEND}"
+PATCHES=(
+ # https://bugs.gentoo.org/880985 https://github.com/marvinkreis/rofi-file-browser-extended/pull/49
+ "${FILESDIR}/${PN}-1.3.1-fix-function-pointer-initialization.patch"
+)
+
src_prepare() {
# Delete the lines in CMakeLists.txt that install the man page.
sed -i "45,56d" CMakeLists.txt || die
- default
cmake_src_prepare
}