summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-03-21 21:43:26 +0100
committerJeroen Roovers <jer@gentoo.org>2018-03-21 21:44:19 +0100
commit3fed9abfd7e2b4b94c17d50410aab10b81c5aa76 (patch)
treebca820ffe1f4b5b9c614153054154c60d881810d /x11-misc/rofi/rofi-1.5.1.ebuild
parentdev-python/ipython: add ~arm, bug #604532 (diff)
downloadgentoo-3fed9abfd7e2b4b94c17d50410aab10b81c5aa76.tar.gz
gentoo-3fed9abfd7e2b4b94c17d50410aab10b81c5aa76.tar.bz2
gentoo-3fed9abfd7e2b4b94c17d50410aab10b81c5aa76.zip
x11-misc/rofi: Version 1.5.1.
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'x11-misc/rofi/rofi-1.5.1.ebuild')
-rw-r--r--x11-misc/rofi/rofi-1.5.1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/rofi/rofi-1.5.1.ebuild b/x11-misc/rofi/rofi-1.5.1.ebuild
new file mode 100644
index 000000000000..b1d04b298f2c
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.5.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://github.com/DaveDavenport/rofi/"
+SRC_URI="${HOMEPAGE}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test windowmode"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/freetype
+ x11-libs/cairo[xcb]
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto
+ x11-proto/xproto
+ test? ( >=dev-libs/check-0.11 )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+ "${FILESDIR}"/${PN}-1.5.0-gtk-settings-test.patch
+)
+
+src_prepare() {
+ if use test; then
+ sed -i -e 's|"/tmp/rofi-test.pid"|"'"$T"'/rofi-test.pid"|g' test/helper-pidfile.c || die
+ fi
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+
+ econf \
+ $(use_enable test check) \
+ $(use_enable windowmode)
+}