summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2018-10-31 17:03:53 +0100
committerSebastian Pipping <sping@gentoo.org>2018-10-31 17:04:34 +0100
commit1c81a79e25867c100bac9c45445da1c0f73254ed (patch)
treee49b9eff9d1c39d933fddab699d7d8cb3723518a /x11-misc/safeeyes/safeeyes-2.0.6_p15.ebuild
parentmedia-sound/pulseeffects: 4.4.0 bump (diff)
downloadgentoo-1c81a79e25867c100bac9c45445da1c0f73254ed.tar.gz
gentoo-1c81a79e25867c100bac9c45445da1c0f73254ed.tar.bz2
gentoo-1c81a79e25867c100bac9c45445da1c0f73254ed.zip
x11-misc/safeeyes: 2.0.6_p15 (with postpone-until-idle feature)
Related: https://github.com/slgobinath/SafeEyes/issues/261#issuecomment-434551505 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'x11-misc/safeeyes/safeeyes-2.0.6_p15.ebuild')
-rw-r--r--x11-misc/safeeyes/safeeyes-2.0.6_p15.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/safeeyes-2.0.6_p15.ebuild b/x11-misc/safeeyes/safeeyes-2.0.6_p15.ebuild
new file mode 100644
index 000000000000..d9dd24cdec58
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.0.6_p15.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+inherit gnome2-utils xdg distutils-r1
+
+MY_PV=65fc4043a6ee4c1087f40a8e7b480645776c7b4e
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+SRC_URI="https://github.com/slgobinath/SafeEyes/archive/${MY_PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="${PYTHON_DEPS}"
+DEPEND="${CDEPEND}
+ >=dev-python/setuptools-38.6.0[${PYTHON_USEDEP}]
+ "
+RDEPEND="${CDEPEND}
+ dev-libs/libappindicator:3
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-misc/xprintidle
+ "
+
+S="${WORKDIR}"/SafeEyes-${MY_PV}
+
+DOCS=(
+ README.md
+)
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}