summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-03-09 15:56:46 +0100
committerSebastian Pipping <sping@gentoo.org>2019-03-09 17:33:36 +0100
commit076e8a1b2028f510f3d7ef53123a70b5725731a5 (patch)
tree3a24bac1f6e157b543df57177a511981cbc2b2ad /x11-misc/safeeyes/safeeyes-2.0.8.1.ebuild
parentapp-admin/conky: Revision bump to conky-1.10.8-r8. (diff)
downloadgentoo-076e8a1b2028f510f3d7ef53123a70b5725731a5.tar.gz
gentoo-076e8a1b2028f510f3d7ef53123a70b5725731a5.tar.bz2
gentoo-076e8a1b2028f510f3d7ef53123a70b5725731a5.zip
x11-misc/safeeyes: 2.0.8.1
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'x11-misc/safeeyes/safeeyes-2.0.8.1.ebuild')
-rw-r--r--x11-misc/safeeyes/safeeyes-2.0.8.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/safeeyes-2.0.8.1.ebuild b/x11-misc/safeeyes/safeeyes-2.0.8.1.ebuild
new file mode 100644
index 000000000000..1980a39f2965
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.0.8.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+inherit gnome2-utils xdg distutils-r1
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="${PYTHON_DEPS}"
+DEPEND="${CDEPEND}
+ >=dev-python/setuptools-38.6.0[${PYTHON_USEDEP}]
+ "
+RDEPEND="${CDEPEND}
+ dev-libs/libappindicator:3
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-misc/xprintidle
+ "
+
+DOCS=(
+ README.md
+)
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}