summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2019-01-22 14:43:54 +0100
committerSebastian Pipping <sping@gentoo.org>2019-01-22 14:49:11 +0100
commite4c7f98403d6252220024fcfc7f8d03845c71433 (patch)
treea9d12653e0ec85f7a635ee98ba6a26b61a7f21ee /x11-misc/safeeyes/safeeyes-2.0.8.ebuild
parentdev-python/python-xlib: Python 3.7 (diff)
downloadgentoo-e4c7f98403d6252220024fcfc7f8d03845c71433.tar.gz
gentoo-e4c7f98403d6252220024fcfc7f8d03845c71433.tar.bz2
gentoo-e4c7f98403d6252220024fcfc7f8d03845c71433.zip
x11-misc/safeeyes: 2.0.8
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'x11-misc/safeeyes/safeeyes-2.0.8.ebuild')
-rw-r--r--x11-misc/safeeyes/safeeyes-2.0.8.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/safeeyes-2.0.8.ebuild b/x11-misc/safeeyes/safeeyes-2.0.8.ebuild
new file mode 100644
index 000000000000..1980a39f2965
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.0.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6,7} )
+inherit gnome2-utils xdg distutils-r1
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="${PYTHON_DEPS}"
+DEPEND="${CDEPEND}
+ >=dev-python/setuptools-38.6.0[${PYTHON_USEDEP}]
+ "
+RDEPEND="${CDEPEND}
+ dev-libs/libappindicator:3
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-misc/xprintidle
+ "
+
+DOCS=(
+ README.md
+)
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ gnome2_icon_cache_update
+}