summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2020-12-26 16:51:41 +0100
committerSebastian Pipping <sping@gentoo.org>2020-12-26 16:52:40 +0100
commit2c23770271229055dce9c4687e5057c1070ef143 (patch)
tree7278723b210ac09f93eec4db9ec0c7f0c9fa34ba /x11-misc/safeeyes/safeeyes-2.0.9-r2.ebuild
parentnet-im/element-desktop-bin: upgrade 1.7.15 -> 1.7.16 (diff)
downloadgentoo-2c23770271229055dce9c4687e5057c1070ef143.tar.gz
gentoo-2c23770271229055dce9c4687e5057c1070ef143.tar.bz2
gentoo-2c23770271229055dce9c4687e5057c1070ef143.zip
x11-misc/safeeyes: 2.1.1 + add missing deps
Closes: https://bugs.gentoo.org/761316 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.12, Repoman-3.0.2
Diffstat (limited to 'x11-misc/safeeyes/safeeyes-2.0.9-r2.ebuild')
-rw-r--r--x11-misc/safeeyes/safeeyes-2.0.9-r2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/safeeyes-2.0.9-r2.ebuild b/x11-misc/safeeyes/safeeyes-2.0.9-r2.ebuild
new file mode 100644
index 000000000000..645b84ffc08d
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.0.9-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit xdg distutils-r1
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="${PYTHON_DEPS}"
+DEPEND="${CDEPEND}
+ >=dev-python/setuptools-38.6.0[${PYTHON_USEDEP}]
+ "
+RDEPEND="${CDEPEND}
+ dev-libs/libappindicator:3[introspection]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+DOCS=(
+ README.md
+)
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}