summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-02-15 01:22:59 +0100
committerSebastian Pipping <sping@gentoo.org>2021-02-15 01:22:59 +0100
commitb55c8e7cdd8f563174b99bd62a2eea436c2063ea (patch)
tree3dd87c39c283af99d2a0c1fdccf66b13cfba0c81 /x11-misc/safeeyes/safeeyes-2.1.2.ebuild
parentdev-ruby/facter: switch to cmake from cmake-utils and remove 9999 (diff)
downloadgentoo-b55c8e7cdd8f563174b99bd62a2eea436c2063ea.tar.gz
gentoo-b55c8e7cdd8f563174b99bd62a2eea436c2063ea.tar.bz2
gentoo-b55c8e7cdd8f563174b99bd62a2eea436c2063ea.zip
x11-misc/safeeyes: 2.1.2
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.14, Repoman-3.0.2
Diffstat (limited to 'x11-misc/safeeyes/safeeyes-2.1.2.ebuild')
-rw-r--r--x11-misc/safeeyes/safeeyes-2.1.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/safeeyes-2.1.2.ebuild b/x11-misc/safeeyes/safeeyes-2.1.2.ebuild
new file mode 100644
index 000000000000..9f1c4ee65890
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.1.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit xdg distutils-r1
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+CDEPEND="${PYTHON_DEPS}"
+DEPEND="${CDEPEND}
+ >=dev-python/setuptools-38.6.0[${PYTHON_USEDEP}]
+ "
+RDEPEND="${CDEPEND}
+ dev-libs/libappindicator:3[introspection]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+DOCS=(
+ README.md
+)
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}