summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-09-05 02:16:26 +0200
committerSebastian Pipping <sping@gentoo.org>2021-09-05 02:16:26 +0200
commitd8aa2a2a13b3e02c8cfb6877499ff31fe43c6449 (patch)
treefff8ca684f57b556bd19c10ddd47825b32975867 /x11-misc/safeeyes/safeeyes-2.1.3-r1.ebuild
parentsys-fs/udisks: require newer polkit #695520 (diff)
downloadgentoo-d8aa2a2a13b3e02c8cfb6877499ff31fe43c6449.tar.gz
gentoo-d8aa2a2a13b3e02c8cfb6877499ff31fe43c6449.tar.bz2
gentoo-d8aa2a2a13b3e02c8cfb6877499ff31fe43c6449.zip
x11-misc/safeeyes: Update DISTUTILS_USE_SETUPTOOLS + py3.10
Closes: https://bugs.gentoo.org/811396 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.22, Repoman-3.0.3
Diffstat (limited to 'x11-misc/safeeyes/safeeyes-2.1.3-r1.ebuild')
-rw-r--r--x11-misc/safeeyes/safeeyes-2.1.3-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/safeeyes-2.1.3-r1.ebuild b/x11-misc/safeeyes/safeeyes-2.1.3-r1.ebuild
new file mode 100644
index 000000000000..a8758f0a686d
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.1.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+
+inherit xdg distutils-r1
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libappindicator:3[introspection]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+DOCS=(
+ README.md
+)
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}