summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-11-22 03:13:36 +0100
committerSebastian Pipping <sping@gentoo.org>2022-11-22 03:15:38 +0100
commitc34225108256439100685ef87bf2074348b95f8b (patch)
treea05c672b6a6a16dddb57930243b8584536f3bf02 /x11-misc/safeeyes/safeeyes-2.1.4.ebuild
parentapp-text/wgetpaste: add 2.33 (diff)
downloadgentoo-c34225108256439100685ef87bf2074348b95f8b.tar.gz
gentoo-c34225108256439100685ef87bf2074348b95f8b.tar.bz2
gentoo-c34225108256439100685ef87bf2074348b95f8b.zip
x11-misc/safeeyes: 2.1.4 + EAPI 8 + py311 + Python USE fix for Xlib/tk
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'x11-misc/safeeyes/safeeyes-2.1.4.ebuild')
-rw-r--r--x11-misc/safeeyes/safeeyes-2.1.4.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/safeeyes-2.1.4.ebuild b/x11-misc/safeeyes/safeeyes-2.1.4.ebuild
new file mode 100644
index 000000000000..a23286174f04
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.1.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="tk" # for site-packages/Xlib/ext/randr.py
+
+inherit xdg distutils-r1
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libappindicator:3[introspection]
+ dev-python/Babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+DOCS=(
+ README.md
+)
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}