summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngolf Wagner <contact@ingolf-wagner.de>2016-12-21 21:38:28 +0100
committerDavid Seifert <soap@gentoo.org>2017-01-04 23:55:52 +0200
commit676abc6970aa6853a0220206c174be170bee3070 (patch)
tree416ea8e71c8278a2a3bbe984d41ec81751baa29e /x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch
parentsys-apps/sysvinit: block <sys-apps/openrc-0.13 (diff)
downloadgentoo-676abc6970aa6853a0220206c174be170bee3070.tar.gz
gentoo-676abc6970aa6853a0220206c174be170bee3070.tar.bz2
gentoo-676abc6970aa6853a0220206c174be170bee3070.zip
x11-misc/slop: add new package
Closes: https://github.com/gentoo/gentoo/pull/2796
Diffstat (limited to 'x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch')
-rw-r--r--x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch b/x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch
new file mode 100644
index 000000000000..13f79eef2110
--- /dev/null
+++ b/x11-misc/slop/files/slop-4.3.21-no-gengetopt.patch
@@ -0,0 +1,33 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -33,29 +33,6 @@ else()
+ message( FATAL_ERROR "Your operating system isn't supported yet! CMake will now exit." )
+ endif()
+
+-# Here we generate some of our code if we can. I package it pre-generated
+-# so nobody has to go find and install gengetopt if they don't want to.
+-find_program( GENGETOPT_EXECUTABLE gengetopt
+- DOC "A tool to generate code to grab command line options." )
+-find_program( SED_EXECUTABLE sed )
+-if ( GENGETOPT_EXECUTABLE AND SED_EXECUTABLE )
+- message( "-- Regenerating cmdline.in" )
+- # gengetopt generates cmdline.h, then we move it to cmdline.in.
+- execute_process( COMMAND "${GENGETOPT_EXECUTABLE}" "--input=options.ggo"
+- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/src" )
+- file( RENAME "${CMAKE_CURRENT_SOURCE_DIR}/src/cmdline.h" "${CMAKE_CURRENT_SOURCE_DIR}/src/cmdline.in" )
+- # Due to a bug in gengetopt, we have to manually insert some code.
+- # Replace the first instance of REPLACEME with some text.
+- # Eight backslashes = two in the code because of how many instances of escaping is happening.
+- execute_process( COMMAND "${SED_EXECUTABLE}" "-i" "0,/REPLACEME/{s/REPLACEME/X=%x\\\\\\\\nY=%y\\\\\\\\nW=%w\\\\\\\\nH=%h\\\\\\\\nG=%g\\\\\\\\nID=%i\\\\\\\\nCancel=%c\\\\\\\\n/}" "cmdline.c"
+- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/src" )
+- # Then replace remaining instances.
+- execute_process( COMMAND "${SED_EXECUTABLE}" "-i" "s/REPLACEME/X=%x\\\\nY=%y\\\\nW=%w\\\\nH=%h\\\\nG=%g\\\\nID=%i\\\\nCancel=%c\\\\n/" "cmdline.c"
+- WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}/src" )
+-else()
+- message( "Warning: Command gengetopt or sed not found! Won't regenerate command line code. (If you're just compiling this doesn't matter.)" )
+-endif()
+-
+ # By default our src/options.ggo has our cmake versions variables for
+ # the 'version ""' line. We replace them here.
+ # The ${CMAKE_SOURCE_DIR} is there to fix problems with OpenBSD's out-of-source build black magic.