summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/spnavcfg/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/spnavcfg/files')
-rw-r--r--x11-misc/spnavcfg/files/spnavcfg-0.2.1-custom-flags.patch44
-rw-r--r--x11-misc/spnavcfg/files/spnavcfg-0.2.1-destdir.patch16
-rw-r--r--x11-misc/spnavcfg/files/spnavcfg-0.2.1-x11-libs.patch12
3 files changed, 72 insertions, 0 deletions
diff --git a/x11-misc/spnavcfg/files/spnavcfg-0.2.1-custom-flags.patch b/x11-misc/spnavcfg/files/spnavcfg-0.2.1-custom-flags.patch
new file mode 100644
index 000000000000..5e4c788dcffe
--- /dev/null
+++ b/x11-misc/spnavcfg/files/spnavcfg-0.2.1-custom-flags.patch
@@ -0,0 +1,44 @@
+diff -Npur spnavcfg-0.2.1.orig/Makefile.in spnavcfg-0.2.1/Makefile.in
+--- spnavcfg-0.2.1.orig/Makefile.in 2012-01-31 22:16:40.789374658 +0100
++++ spnavcfg-0.2.1/Makefile.in 2012-01-31 22:17:01.146374359 +0100
+@@ -5,8 +5,8 @@ warn = -Wall -Wno-int-to-pointer-cast -W
+
+ CC = gcc
+ INSTALL = install
+-CFLAGS = -pedantic $(warn) $(dbg) $(opt) `pkg-config --cflags gtk+-2.0`
+-LDFLAGS = `pkg-config --libs gtk+-2.0`
++CFLAGS = $(user_cflags) `pkg-config --cflags gtk+-2.0`
++LDFLAGS = $(user_ldflags) `pkg-config --libs gtk+-2.0`
+
+ $(bin): $(obj)
+ $(CC) -o $@ $(obj) $(LDFLAGS)
+diff -Npur spnavcfg-0.2.1.orig/configure spnavcfg-0.2.1/configure
+--- spnavcfg-0.2.1.orig/configure 2012-01-31 22:16:40.789374658 +0100
++++ spnavcfg-0.2.1/configure 2012-01-31 22:17:01.146374359 +0100
+@@ -43,6 +43,12 @@ done
+ echo " prefix: $PREFIX"
+ echo " optimize for speed: $OPT"
+ echo " include debugging symbols: $DBG"
++if [ -n "$CFLAGS" ]; then
++ echo " cflags: $CFLAGS"
++fi
++if [ -n "$LDFLAGS" ]; then
++ echo " ldflags: $LDFLAGS"
++fi
+ echo
+
+ # create Makefile
+@@ -58,6 +64,13 @@ if [ "$OPT" = 'yes' ]; then
+ echo 'opt = -O3' >>Makefile
+ fi
+
++if [ -n "$CFLAGS" ]; then
++ echo "user_cflags = $CFLAGS" >>Makefile
++fi
++if [ -n "$LDFLAGS" ]; then
++ echo "user_ldflags = $LDFLAGS" >>Makefile
++fi
++
+ cat "$srcdir/Makefile.in" >>Makefile
+
+ echo ''
diff --git a/x11-misc/spnavcfg/files/spnavcfg-0.2.1-destdir.patch b/x11-misc/spnavcfg/files/spnavcfg-0.2.1-destdir.patch
new file mode 100644
index 000000000000..8e6848baa102
--- /dev/null
+++ b/x11-misc/spnavcfg/files/spnavcfg-0.2.1-destdir.patch
@@ -0,0 +1,16 @@
+diff -Npur spnavcfg-0.2.1.orig/Makefile.in spnavcfg-0.2.1/Makefile.in
+--- spnavcfg-0.2.1.orig/Makefile.in 2012-01-24 19:50:04.738222230 +0100
++++ spnavcfg-0.2.1/Makefile.in 2012-01-24 19:51:13.199221053 +0100
+@@ -20,9 +20,9 @@ clean:
+
+ .PHONY: install
+ install:
+- $(INSTALL) -d $(PREFIX)/bin
+- $(INSTALL) -m 4775 $(bin) $(PREFIX)/bin/$(bin)
++ $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
++ $(INSTALL) -m 4775 $(bin) $(DESTDIR)$(PREFIX)/bin/$(bin)
+
+ .PHONY: uninstall
+ uninstall:
+- rm -f $(PREFIX)/bin/$(bin)
++ rm -f $(DESTDIR)$(PREFIX)/bin/$(bin)
diff --git a/x11-misc/spnavcfg/files/spnavcfg-0.2.1-x11-libs.patch b/x11-misc/spnavcfg/files/spnavcfg-0.2.1-x11-libs.patch
new file mode 100644
index 000000000000..7294013ac5c4
--- /dev/null
+++ b/x11-misc/spnavcfg/files/spnavcfg-0.2.1-x11-libs.patch
@@ -0,0 +1,12 @@
+diff -Npur spnavcfg-0.2.1.orig/Makefile.in spnavcfg-0.2.1/Makefile.in
+--- spnavcfg-0.2.1.orig/Makefile.in 2012-01-31 22:10:35.832381151 +0100
++++ spnavcfg-0.2.1/Makefile.in 2012-01-31 22:11:14.254380520 +0100
+@@ -6,7 +6,7 @@ warn = -Wall -Wno-int-to-pointer-cast -W
+ CC = gcc
+ INSTALL = install
+ CFLAGS = $(user_cflags) `pkg-config --cflags gtk+-2.0`
+-LDFLAGS = $(user_ldflags) `pkg-config --libs gtk+-2.0`
++LDFLAGS = $(user_ldflags) `pkg-config --libs gtk+-2.0` -lX11
+
+ $(bin): $(obj)
+ $(CC) -o $@ $(obj) $(LDFLAGS)