summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJaco Kroon <jaco@uls.co.za>2023-05-10 12:21:35 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-05-20 15:50:06 +0300
commit86005ddb9e7a8c82101ac0a5957c30fe5a8803b1 (patch)
tree29fc4887cde2e8ff5513f65b2ec947f2ca43313f /x11-misc/stalonetray/stalonetray-0.8.5.ebuild
parentnet-p2p/kubo: add 0.20.0 (diff)
downloadgentoo-86005ddb9e7a8c82101ac0a5957c30fe5a8803b1.tar.gz
gentoo-86005ddb9e7a8c82101ac0a5957c30fe5a8803b1.tar.bz2
gentoo-86005ddb9e7a8c82101ac0a5957c30fe5a8803b1.zip
x11-misc/stalonetray: add 0.8.5
Closes: https://bugs.gentoo.org/898848 Closes: https://891183.bugs.gentoo.org/attachment.cgi?id=848715 Signed-off-by: Jaco Kroon <jaco@uls.co.za> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc/stalonetray/stalonetray-0.8.5.ebuild')
-rw-r--r--x11-misc/stalonetray/stalonetray-0.8.5.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/stalonetray/stalonetray-0.8.5.ebuild b/x11-misc/stalonetray/stalonetray-0.8.5.ebuild
new file mode 100644
index 000000000000..8848afa772cb
--- /dev/null
+++ b/x11-misc/stalonetray/stalonetray-0.8.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="System tray utility including support for KDE system tray icons"
+HOMEPAGE="https://kolbusa.github.io/stalonetray/"
+SRC_URI="https://github.com/kolbusa/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+IUSE="debug +graceful-exit"
+
+RDEPEND="x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="app-text/docbook-xml-dtd
+ dev-libs/libxslt"
+
+DOCS=( AUTHORS BUGS COPYING NEWS README.md TODO stalonetrayrc.sample stalonetray.html )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable debug) \
+ $(use_enable graceful-exit) \
+ --enable-native-kde
+}
+
+src_compile() {
+ emake
+ emake dist
+}