summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPiotr Karbowski <slashbeast@gentoo.org>2020-08-17 17:54:51 +0200
committerPiotr Karbowski <slashbeast@gentoo.org>2020-08-17 17:56:07 +0200
commit6f93f6e135558adfefdb8eca50c70b9e5be7ed33 (patch)
tree4f611dca82ef5ec1d31938100be0cfb21e7a1714 /x11-misc/sunflower/sunflower-0.4_p20200716-r1.ebuild
parentsci-electronics/gazebo: bump to 11.1.0 (diff)
downloadgentoo-6f93f6e135558adfefdb8eca50c70b9e5be7ed33.tar.gz
gentoo-6f93f6e135558adfefdb8eca50c70b9e5be7ed33.tar.bz2
gentoo-6f93f6e135558adfefdb8eca50c70b9e5be7ed33.zip
x11-misc/sunflower: fix deps, chardet and gi are imported in setup.py...
Closes: https://bugs.gentoo.org/737546 Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
Diffstat (limited to 'x11-misc/sunflower/sunflower-0.4_p20200716-r1.ebuild')
-rw-r--r--x11-misc/sunflower/sunflower-0.4_p20200716-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/sunflower/sunflower-0.4_p20200716-r1.ebuild b/x11-misc/sunflower/sunflower-0.4_p20200716-r1.ebuild
new file mode 100644
index 000000000000..7c86bc5a3e18
--- /dev/null
+++ b/x11-misc/sunflower/sunflower-0.4_p20200716-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
+HOMEPAGE="https://github.com/MeanEYE/Sunflower
+ https://sunflower-fm.org/"
+SRC_URI="https://dev.gentoo.org/~slashbeast/distfiles/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}
+ dev-python/pycairo[${PYTHON_USEDEP}]
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}