summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-11-03 20:24:07 -0400
committerTim Harder <radhermit@gentoo.org>2016-11-03 20:26:57 -0400
commita3423af5611f8b4b47c2a67076a224aef9f3ff18 (patch)
tree05613079633866e2a15c4a026c40cf4a839e1c21 /x11-misc/sxhkd/sxhkd-0.5.7.ebuild
parentdev-python/pygit2: version bump to 0.24.2 (diff)
downloadgentoo-a3423af5611f8b4b47c2a67076a224aef9f3ff18.tar.gz
gentoo-a3423af5611f8b4b47c2a67076a224aef9f3ff18.tar.bz2
gentoo-a3423af5611f8b4b47c2a67076a224aef9f3ff18.zip
x11-misc/sxhkd: version bump to 0.5.7
Diffstat (limited to 'x11-misc/sxhkd/sxhkd-0.5.7.ebuild')
-rw-r--r--x11-misc/sxhkd/sxhkd-0.5.7.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/sxhkd/sxhkd-0.5.7.ebuild b/x11-misc/sxhkd/sxhkd-0.5.7.ebuild
new file mode 100644
index 000000000000..26cfda4dee80
--- /dev/null
+++ b/x11-misc/sxhkd/sxhkd-0.5.7.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs systemd
+
+DESCRIPTION="Simple X hotkey daemon"
+HOMEPAGE="https://github.com/baskerville/sxhkd/"
+SRC_URI="https://github.com/baskerville/sxhkd/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libxcb
+ x11-libs/xcb-util-keysyms"
+DEPEND="${RDEPEND}
+ x11-libs/xcb-util"
+
+src_compile() {
+ emake CC="$(tc-getCC)" PREFIX=/usr
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+ systemd_dounit contrib/systemd/${PN}.service
+}