summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-04-14 17:15:06 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-04-14 17:15:56 -0700
commit24bb86477e57bbe60ca4ae86455b5afde49c1dff (patch)
tree638e6152fefe443e136e0f996a6dd7c57598a8ad /x11-misc/tdrop/tdrop-0.4.0.ebuild
parentx11-libs/libwnck: Stabilize 2.31.0-r1 ppc64, #782847 (diff)
downloadgentoo-24bb86477e57bbe60ca4ae86455b5afde49c1dff.tar.gz
gentoo-24bb86477e57bbe60ca4ae86455b5afde49c1dff.tar.bz2
gentoo-24bb86477e57bbe60ca4ae86455b5afde49c1dff.zip
x11-misc/tdrop: bump to 0.4.0
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'x11-misc/tdrop/tdrop-0.4.0.ebuild')
-rw-r--r--x11-misc/tdrop/tdrop-0.4.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/tdrop/tdrop-0.4.0.ebuild b/x11-misc/tdrop/tdrop-0.4.0.ebuild
new file mode 100644
index 000000000000..695b437b87d3
--- /dev/null
+++ b/x11-misc/tdrop/tdrop-0.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WM-Independent Dropdown Creator"
+HOMEPAGE="https://github.com/noctuid/tdrop"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/noctuid/tdrop"
+else
+ SRC_URI="https://github.com/noctuid/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ sys-process/procps
+ x11-apps/xprop
+ x11-apps/xrandr
+ x11-apps/xwininfo
+ x11-misc/xdotool
+"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin tdrop
+ doman tdrop.1
+ dodoc README.org
+}