summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-04-10 12:40:53 +0300
committerDavid Seifert <soap@gentoo.org>2017-04-16 20:57:09 +0200
commit97ac77b464d24a6e94d6aaabebd10ab54c0b2b72 (patch)
treeea43d438ee131cdecfd5a63b647ffd5129875df0 /x11-misc/trayer-srg/trayer-srg-1.1.7.ebuild
parentdev-python/python-keystoneclient: 3.5.1 stable amd64 and x86 (diff)
downloadgentoo-97ac77b464d24a6e94d6aaabebd10ab54c0b2b72.tar.gz
gentoo-97ac77b464d24a6e94d6aaabebd10ab54c0b2b72.tar.bz2
gentoo-97ac77b464d24a6e94d6aaabebd10ab54c0b2b72.zip
x11-misc/trayer-srg: Bump to 1.1.7
Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4406
Diffstat (limited to 'x11-misc/trayer-srg/trayer-srg-1.1.7.ebuild')
-rw-r--r--x11-misc/trayer-srg/trayer-srg-1.1.7.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/trayer-srg/trayer-srg-1.1.7.ebuild b/x11-misc/trayer-srg/trayer-srg-1.1.7.ebuild
new file mode 100644
index 000000000000..2bbf335312e0
--- /dev/null
+++ b/x11-misc/trayer-srg/trayer-srg-1.1.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="trayer fork with multi monitor support and cleaned up codebase"
+HOMEPAGE="https://github.com/sargon/trayer-srg"
+SRC_URI="https://github.com/sargon/${PN}/archive/${P/-srg/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}"/${PN}-trayer-${PV}
+
+src_configure() {
+ # Custom configure script
+ ./configure --prefix="${EPREFIX}" || die
+}
+
+src_compile() {
+ emake DEVEL=1 TARGET=${PN} CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}