summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-02 15:31:03 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-02 15:34:44 +0100
commitfaa96709d70c6affb9c0c445637376672237d797 (patch)
tree873f5b9f69ce1a65e7d1007adbd5c6524bb241df /x11-misc/trayer-srg/trayer-srg-1.1.8.ebuild
parentx11-misc/trayer: Fix CFLAGS=-fno-common (diff)
downloadgentoo-faa96709d70c6affb9c0c445637376672237d797.tar.gz
gentoo-faa96709d70c6affb9c0c445637376672237d797.tar.bz2
gentoo-faa96709d70c6affb9c0c445637376672237d797.zip
x11-misc/trayer-srg: Version 1.1.8
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Closes: https://bugs.gentoo.org/671390 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/trayer-srg/trayer-srg-1.1.8.ebuild')
-rw-r--r--x11-misc/trayer-srg/trayer-srg-1.1.8.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/trayer-srg/trayer-srg-1.1.8.ebuild b/x11-misc/trayer-srg/trayer-srg-1.1.8.ebuild
new file mode 100644
index 000000000000..8a9b9e21d068
--- /dev/null
+++ b/x11-misc/trayer-srg/trayer-srg-1.1.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="trayer fork with multi monitor support and cleaned up codebase"
+HOMEPAGE="https://github.com/sargon/trayer-srg"
+SRC_URI="https://github.com/sargon/${PN}/archive/${P/-srg/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}"/${PN}-trayer-${PV}
+
+src_configure() {
+ # Custom configure script
+ ./configure --prefix="${EPREFIX}" || die
+}
+
+src_compile() {
+ emake DEVEL=1 TARGET=${PN} CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}