summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-03-25 12:34:00 +0200
committerMart Raudsepp <leio@gentoo.org>2017-03-25 12:40:06 +0200
commit865cdd57ef94a65a9b75d88fe18384496cae83bc (patch)
tree4892ec2f7422ebfca060995950503978d0d19da1 /x11-misc/trayer/trayer-1.0-r3.ebuild
parentprofiles: add the reason to keep gst-plugins-ffmpeg p.mask around (diff)
downloadgentoo-865cdd57ef94a65a9b75d88fe18384496cae83bc.tar.gz
gentoo-865cdd57ef94a65a9b75d88fe18384496cae83bc.tar.bz2
gentoo-865cdd57ef94a65a9b75d88fe18384496cae83bc.zip
x11-misc/trayer: Patch to remove dependency on gdk-pixbuf[X]
Package-Manager: Portage-2.3.5, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4295
Diffstat (limited to 'x11-misc/trayer/trayer-1.0-r3.ebuild')
-rw-r--r--x11-misc/trayer/trayer-1.0-r3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/trayer/trayer-1.0-r3.ebuild b/x11-misc/trayer/trayer-1.0-r3.ebuild
new file mode 100644
index 000000000000..adb954195460
--- /dev/null
+++ b/x11-misc/trayer/trayer-1.0-r3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Lightweight GTK+ based systray for UNIX desktop"
+HOMEPAGE="http://home.gna.org/fvwm-crystal/"
+SRC_URI="http://download.gna.org/fvwm-crystal/trayer/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-dont-include-gdk-pixbuf-xlib.patch
+ "${FILESDIR}"/${P}-as-needed-and-pre-stripped.patch
+)
+
+src_compile() {
+ emake -j1 CC=$(tc-getCC) CFLAGS="${CFLAGS}" CPPFLAGS="${CPPFLAGS}"
+}
+
+src_install() {
+ dobin trayer
+ doman trayer.1
+ einstalldocs
+}