summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-03-18 14:41:31 +0100
committerJeroen Roovers <jer@gentoo.org>2017-03-18 14:42:37 +0100
commit7c76bc1cc378eed2832fc9f557156e238b911f69 (patch)
tree0c3f500ced9a6edaaaef2b27cbabc3a645962581 /x11-misc/treeline/treeline-2.1.1.ebuild
parentmail-client/roundcube: Bump to v1.2.4 (diff)
downloadgentoo-7c76bc1cc378eed2832fc9f557156e238b911f69.tar.gz
gentoo-7c76bc1cc378eed2832fc9f557156e238b911f69.tar.bz2
gentoo-7c76bc1cc378eed2832fc9f557156e238b911f69.zip
x11-misc/treeline: Version bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'x11-misc/treeline/treeline-2.1.1.ebuild')
-rw-r--r--x11-misc/treeline/treeline-2.1.1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/treeline/treeline-2.1.1.ebuild b/x11-misc/treeline/treeline-2.1.1.ebuild
new file mode 100644
index 000000000000..6329f671d1fc
--- /dev/null
+++ b/x11-misc/treeline/treeline-2.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_4 )
+PYTHON_REQ_USE="xml"
+
+inherit eutils python-single-r1
+
+DESCRIPTION="TreeLine is a structured information storage program"
+HOMEPAGE="http://treeline.bellz.org/"
+SRC_URI="mirror://sourceforge/project/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ ${DEPEND}
+ dev-python/PyQt4[X,${PYTHON_USEDEP}]
+"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S="${WORKDIR}/TreeLine"
+
+src_prepare() {
+ rm doc/LICENSE || die
+
+ python_export PYTHON_SITEDIR
+ sed -i "s;prefixDir, 'lib;'${PYTHON_SITEDIR};" install.py || die
+}
+
+src_install() {
+ "${EPYTHON}" install.py -x -p /usr/ -d /usr/share/doc/${PF} -b "${D}" || die
+}