summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/winswitch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/winswitch')
-rw-r--r--x11-misc/winswitch/Manifest1
-rw-r--r--x11-misc/winswitch/files/winswitch-0.12.18-PIL.patch84
-rw-r--r--x11-misc/winswitch/metadata.xml13
-rw-r--r--x11-misc/winswitch/winswitch-0.12.18-r1.ebuild48
4 files changed, 146 insertions, 0 deletions
diff --git a/x11-misc/winswitch/Manifest b/x11-misc/winswitch/Manifest
new file mode 100644
index 000000000000..12b8d7d9e647
--- /dev/null
+++ b/x11-misc/winswitch/Manifest
@@ -0,0 +1 @@
+DIST winswitch-0.12.18.src.tar.bz2 1193952 SHA256 466a6906d98b47381f0528410e1d833354dc20ea2855a0c0424a10c90cbc7e08 SHA512 841d269119ab3118acbbd7ad1c2d27203b45a72213fd9e8d75d937224d973e78110a05e5772a3856a3f3c9440633b200c7a0eab67a3d5b0125de22f33084819e WHIRLPOOL 18d783e8589b687435a278e8acce83a31fb720b8ec29a58e78a2f61649687ac2e998d11e780863cba5b26d062872f314b07ab5a277f9d1a67b5a446647df0d25
diff --git a/x11-misc/winswitch/files/winswitch-0.12.18-PIL.patch b/x11-misc/winswitch/files/winswitch-0.12.18-PIL.patch
new file mode 100644
index 000000000000..be6484dd1084
--- /dev/null
+++ b/x11-misc/winswitch/files/winswitch-0.12.18-PIL.patch
@@ -0,0 +1,84 @@
+https://bugs.gentoo.org/show_bug.cgi?id=471564
+https://winswitch.org/trac/ticket/238
+
+--- winswitch-0.12.18/winswitch/virt/xpra_client_util.py
++++ winswitch-0.12.18/winswitch/virt/xpra_client_util.py
+@@ -95,8 +95,8 @@
+ widgets = []
+ has_pil = False
+ try:
+- import Image
+- has_pil = Image is not None
++ import PIL.Image
++ has_pil = PIL.Image is not None
+ except:
+ pass
+ jw = self.get_encoding_widget(server, server_command, options, change_cb, has_pil)
+--- winswitch-0.12.18/winswitch/ui/capture_util.py
++++ winswitch-0.12.18/winswitch/ui/capture_util.py
+@@ -125,16 +125,16 @@
+ #resize it
+ img_data = load_binary_file(self.filename)
+ import StringIO
+- import Image
+- image = Image.open(StringIO.StringIO(img_data))
++ import PIL.Image
++ image = PIL.Image.open(StringIO.StringIO(img_data))
+ self.save_resized(image)
+
+ def save_resized(self, image):
+ """ save a PIL.Image after resizing it to thumbnail size """
+- import Image
++ import PIL.Image
+ (w,h) = image.size
+ w,h = self.get_thumbnail_dimensions(w, h)
+- image.thumbnail((w,h), Image.ANTIALIAS)
++ image.thumbnail((w,h), PIL.Image.ANTIALIAS)
+ image.save(self.filename, "PNG")
+
+
+@@ -190,13 +190,13 @@
+
+ def do_capture(self):
+ #force py2exe to include these:
+- import Image
+- import GifImagePlugin
+- import JpegImagePlugin
+- import PngImagePlugin
+- import ImageGrab
+- assert Image and GifImagePlugin and JpegImagePlugin and PngImagePlugin and ImageGrab #avoid pydev warnings
+- screenshot = ImageGrab.grab()
++ import PIL.Image
++ import PIL.GifImagePlugin
++ import PIL.JpegImagePlugin
++ import PIL.PngImagePlugin
++ import PIL.ImageGrab
++ assert PIL.Image and PIL.GifImagePlugin and PIL.JpegImagePlugin and PIL.PngImagePlugin and PIL.ImageGrab #avoid pydev warnings
++ screenshot = PIL.ImageGrab.grab()
+ self.save_resized(screenshot)
+ self.finish()
+
+--- winswitch-0.12.18/winswitch/util/icon_util.py
++++ winswitch-0.12.18/winswitch/util/icon_util.py
+@@ -27,7 +27,7 @@
+ HAS_CAIRO_RSVG = False
+
+ try:
+- import Image
++ import PIL.Image
+ has_PIL = True
+ except:
+ has_PIL = False
+@@ -58,10 +58,10 @@
+ return scaled_data
+
+ def pil_load_scaled_pixmap(filename, size_limit):
+- img = Image.open(filename)
++ img = PIL.Image.open(filename)
+ (w,h) = img.size
+ if w>size_limit or h>size_limit:
+- img.thumbnail((size_limit,size_limit), Image.ANTIALIAS)
++ img.thumbnail((size_limit,size_limit), PIL.Image.ANTIALIAS)
+ assert img
+ return pil_image_to_png_data(img)
+
diff --git a/x11-misc/winswitch/metadata.xml b/x11-misc/winswitch/metadata.xml
new file mode 100644
index 000000000000..475f302a1746
--- /dev/null
+++ b/x11-misc/winswitch/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+</maintainer>
+<upstream>
+ <doc lang="en">http://winswitch.org/documentation/</doc>
+ <bugs-to>https://winswitch.org/trac/report</bugs-to>
+</upstream>
+</pkgmetadata>
+
diff --git a/x11-misc/winswitch/winswitch-0.12.18-r1.ebuild b/x11-misc/winswitch/winswitch-0.12.18-r1.ebuild
new file mode 100644
index 000000000000..cec3bfbe16da
--- /dev/null
+++ b/x11-misc/winswitch/winswitch-0.12.18-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="client server tool to start and control virtual desktops"
+HOMEPAGE="http://winswitch.org"
+SRC_URI="http://winswitch.org/src/${P}.src.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="dev-python/gst-python:0.10[${PYTHON_USEDEP}]
+ dev-python/netifaces[${PYTHON_USEDEP}]
+ dev-python/notify-python[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pygtk[${PYTHON_USEDEP}]
+ dev-python/twisted-core
+ dev-python/twisted-conch
+ media-gfx/xloadimage
+ virtual/python-imaging[${PYTHON_USEDEP}]
+ x11-misc/devilspie"
+DEPEND=""
+
+PATCHES=( "${FILESDIR}"/${P}-PIL.patch )
+
+python_prepare_all() {
+ einfo "Remove bundled Vash"
+ rm -rf skel/share/Vash || die
+ export PREFIX="${EPREFIX}"
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ elog "You might want to install following packages for additional protocol functionality"
+ elog " net-misc/tigervnc[?server]"
+ elog " x11-wm/xpra[?server]"
+ elog " || ( net-misc/nxclient net-misc/nx ) "
+ elog "and net-dns/avahi[python] for automatic server discovery"
+}