summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-01-15 11:34:18 +0100
committerJeroen Roovers <jer@gentoo.org>2019-01-15 11:34:57 +0100
commit075f311d7e8913f0a27f2247faac675ebb94d137 (patch)
treeb3141750811b0b297fde334e6a56ba96595a8e23 /x11-misc/xautolock/xautolock-2.2_p5_p1-r1.ebuild
parentdev-lang/spidermonkey: Stable for HPPA too. (diff)
downloadgentoo-075f311d7e8913f0a27f2247faac675ebb94d137.tar.gz
gentoo-075f311d7e8913f0a27f2247faac675ebb94d137.tar.bz2
gentoo-075f311d7e8913f0a27f2247faac675ebb94d137.zip
x11-misc/xautolock: Use waitpid() instead of wait3()
Fixes: https://bugs.gentoo.org/675242 Package-Manager: Portage-2.3.55, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/xautolock/xautolock-2.2_p5_p1-r1.ebuild')
-rw-r--r--x11-misc/xautolock/xautolock-2.2_p5_p1-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/xautolock/xautolock-2.2_p5_p1-r1.ebuild b/x11-misc/xautolock/xautolock-2.2_p5_p1-r1.ebuild
new file mode 100644
index 000000000000..63dd3677304c
--- /dev/null
+++ b/x11-misc/xautolock/xautolock-2.2_p5_p1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs versionator
+
+DESCRIPTION="An automatic X screen-locker/screen-saver"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/X11/screensavers/"
+
+DEB_REV_MAJ="$(get_version_component_range 3)"
+DEB_REV_MIN="$(get_version_component_range 4)"
+DEB_REVISION="${DEB_REV_MAJ/p}.${DEB_REV_MIN/p}"
+SRC_URI="
+ ${HOMEPAGE}/${P/_p*/}.tgz
+ mirror://debian/pool/main/x/${PN}/${PN}_${PV/_p*/}-${DEB_REVISION}.debian.tar.xz
+"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ x11-libs/libXScrnSaver
+"
+DEPEND="
+ ${RDEPEND}
+ app-text/rman
+ x11-base/xorg-proto
+ x11-misc/imake
+"
+PATCHES=(
+ "${WORKDIR}"/debian/patches/10-fix-memory-corruption.patch
+ "${WORKDIR}"/debian/patches/11-fix-no-dpms.patch
+ "${WORKDIR}"/debian/patches/12-fix-manpage.patch
+ "${WORKDIR}"/debian/patches/13-fix-hppa-build.patch
+ "${FILESDIR}"/${PN}-2.2_p5_p1-waitpid.patch
+)
+S=${WORKDIR}/${P/_p*}
+
+src_configure() {
+ xmkmf || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install () {
+ dobin xautolock
+ newman xautolock.man xautolock.1
+ dodoc Changelog Readme Todo
+}