summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-09-16 06:13:28 +0200
committerJeroen Roovers <jer@gentoo.org>2015-09-16 06:13:28 +0200
commit7157442b92744d6b8ed5b1e45c42a0a79ed86750 (patch)
treee9605183c3e51d903381013602f1340630753005 /x11-misc/xbattbar/xbattbar-1.4.8.ebuild
parentx11-misc/xnots: Live ebuild. (diff)
downloadgentoo-7157442b92744d6b8ed5b1e45c42a0a79ed86750.tar.gz
gentoo-7157442b92744d6b8ed5b1e45c42a0a79ed86750.tar.bz2
gentoo-7157442b92744d6b8ed5b1e45c42a0a79ed86750.zip
x11-misc/xbattbar: Version bump.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-misc/xbattbar/xbattbar-1.4.8.ebuild')
-rw-r--r--x11-misc/xbattbar/xbattbar-1.4.8.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/xbattbar/xbattbar-1.4.8.ebuild b/x11-misc/xbattbar/xbattbar-1.4.8.ebuild
new file mode 100644
index 000000000000..18b2d309dbd0
--- /dev/null
+++ b/x11-misc/xbattbar/xbattbar-1.4.8.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils flag-o-matic multilib python-single-r1 toolchain-funcs
+
+DESCRIPTION="Advanced Power Management battery status display for X"
+HOMEPAGE="http://packages.qa.debian.org/x/xbattbar.html"
+SRC_URI="mirror://debian/pool/main/x/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="
+ dev-lang/perl
+ x11-libs/libX11
+"
+RDEPEND="
+ ${DEPEND}
+ ${PYTHON_DEPS}
+ !ppc? ( >=sys-power/acpi-1.5 )
+" # ppc has APM
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.4.5.patch \
+ "${FILESDIR}"/${PN}-1.4.8-const.patch
+
+ sed -i \
+ -e "s:usr/lib:usr/$(get_libdir):" \
+ xbattbar.c || die
+
+ tc-export PKG_CONFIG
+}
+
+src_compile() {
+ use kernel_linux && append-flags -Dlinux
+ emake \
+ CC=$(tc-getCC) \
+ LIBDIR="$(get_libdir)" \
+ LDFLAGS="${LDFLAGS}"
+ python_fix_shebang ${PN}-check-sys
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="$(get_libdir)" install
+ dodoc README
+}