summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <andreas.sturmlechner@gmail.com>2016-12-10 09:26:15 +0100
committerDavid Seifert <soap@gentoo.org>2016-12-10 23:50:29 +0100
commit72d277cad988df8600b29815083cd9030c02a8f7 (patch)
treead647fe5efc828f67397bc1195495dc698a8210e /x11-misc/xcalib/xcalib-0.9.0_p20161210.ebuild
parentapp-crypt/pinentry: simplify MOC a bit (diff)
downloadgentoo-72d277cad988df8600b29815083cd9030c02a8f7.tar.gz
gentoo-72d277cad988df8600b29815083cd9030c02a8f7.tar.bz2
gentoo-72d277cad988df8600b29815083cd9030c02a8f7.zip
x11-misc/xcalib: 0.9.0 version bump, switch to cmake, EAPI 6
Actually fetch from Github snapshot, release tarball from sourceforge does not work and there have been a few fixes since release. Package-Manager: portage-2.3.0 Closes: https://github.com/gentoo/gentoo/pull/3069
Diffstat (limited to 'x11-misc/xcalib/xcalib-0.9.0_p20161210.ebuild')
-rw-r--r--x11-misc/xcalib/xcalib-0.9.0_p20161210.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/xcalib/xcalib-0.9.0_p20161210.ebuild b/x11-misc/xcalib/xcalib-0.9.0_p20161210.ebuild
new file mode 100644
index 000000000000..7200c2c7bf95
--- /dev/null
+++ b/x11-misc/xcalib/xcalib-0.9.0_p20161210.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="A tiny monitor calibration loader for X.org"
+HOMEPAGE="https://github.com/OpenICC/xcalib"
+COMMIT="95c932996cfc9f792dea4a6c49fec3c1ed2267ac"
+SRC_URI="${HOMEPAGE}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXrandr
+ x11-libs/libXxf86vm
+"
+DEPEND="${RDEPEND}
+ x11-libs/libXext
+ x11-proto/xf86vidmodeproto
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"