summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-29 12:16:47 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-29 12:32:06 +0100
commit5ffe68d79d60fd194ab2faaf997de5104a4ede68 (patch)
treebcfb8604deb234ab009435126e903a198793a6f9 /x11-misc/xcave/xcave-2.4.0.ebuild
parentx11-misc/xnee: Set CFLAGS=-fcommon (diff)
downloadgentoo-5ffe68d79d60fd194ab2faaf997de5104a4ede68.tar.gz
gentoo-5ffe68d79d60fd194ab2faaf997de5104a4ede68.tar.bz2
gentoo-5ffe68d79d60fd194ab2faaf997de5104a4ede68.zip
x11-misc/xcave: Set CFLAGS=-fcommon
Also fix pkg-config variable prefix in configure.ac: ./configure: line 1425: ac_env_libxml-2.0_CFLAGS_set=2.0_CFLAGS+set: command not found (etc.) Package-Manager: Portage-2.3.86, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=706928 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/xcave/xcave-2.4.0.ebuild')
-rw-r--r--x11-misc/xcave/xcave-2.4.0.ebuild26
1 files changed, 22 insertions, 4 deletions
diff --git a/x11-misc/xcave/xcave-2.4.0.ebuild b/x11-misc/xcave/xcave-2.4.0.ebuild
index 3e6245d4498d..96c74893f67f 100644
--- a/x11-misc/xcave/xcave-2.4.0.ebuild
+++ b/x11-misc/xcave/xcave-2.4.0.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools flag-o-matic
DESCRIPTION="View and manage contents of your wine cellar"
HOMEPAGE="http://xcave.free.fr/index-en.php"
@@ -14,13 +15,30 @@ RESTRICT="test"
RDEPEND="
x11-libs/gtk+:2
- dev-libs/libxml2:2"
-DEPEND="${RDEPEND}"
+ dev-libs/libxml2:2
+"
+DEPEND="
+ ${RDEPEND}
+"
BDEPEND="
dev-util/intltool
sys-devel/gettext
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.4.0-pkg-config.patch
+)
+src_prepare() {
+ mkdir m4 || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}
src_install() {
default