summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-20 02:40:34 +0100
committerSam James <sam@gentoo.org>2021-04-20 02:42:28 +0100
commit7ab4763ae11611a921ea5fa1784e656fb6d084b0 (patch)
tree7a0ac54521ab0390ed37c4867f79ca0da9c4681e /x11-misc/xdock/xdock-0.3.0.ebuild
parentx11-misc/xrestop: port to EAPI 7 (diff)
downloadgentoo-7ab4763ae11611a921ea5fa1784e656fb6d084b0.tar.gz
gentoo-7ab4763ae11611a921ea5fa1784e656fb6d084b0.tar.bz2
gentoo-7ab4763ae11611a921ea5fa1784e656fb6d084b0.zip
x11-misc/xdock: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/xdock/xdock-0.3.0.ebuild')
-rw-r--r--x11-misc/xdock/xdock-0.3.0.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/x11-misc/xdock/xdock-0.3.0.ebuild b/x11-misc/xdock/xdock-0.3.0.ebuild
index 6cf304a5efbe..dad806f32209 100644
--- a/x11-misc/xdock/xdock-0.3.0.ebuild
+++ b/x11-misc/xdock/xdock-0.3.0.ebuild
@@ -1,25 +1,30 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools epatch
+EAPI=7
-DESCRIPTION="emulates Window Maker docks (runs in any window manager)"
+inherit autotools
+
+DESCRIPTION="Emulates Window Maker docks (runs in any window manager)"
HOMEPAGE="http://xdock.sourceforge.net"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
RDEPEND="x11-libs/libX11"
DEPEND="${RDEPEND}"
DOCS=( API AUTHORS ChangeLog README TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.2.0-ldconfig.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.2.0-ldconfig.patch
+ default
+
sed -i -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' configure.ac || die
eautoreconf
}