summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 05:12:07 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:12 -0400
commit2b9bf983be4237399e3b48c27f63d871da9b9a9e (patch)
treebd94015d568240bb296a8a9210e7957c8bc4846d /x11-misc/xearth
parentx11-misc/xbatt: fix build with clang16 (diff)
downloadgentoo-2b9bf983be4237399e3b48c27f63d871da9b9a9e.tar.gz
gentoo-2b9bf983be4237399e3b48c27f63d871da9b9a9e.tar.bz2
gentoo-2b9bf983be4237399e3b48c27f63d871da9b9a9e.zip
x11-misc/xearth: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc/xearth')
-rw-r--r--x11-misc/xearth/xearth-1.1-r1.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/x11-misc/xearth/xearth-1.1-r1.ebuild b/x11-misc/xearth/xearth-1.1-r1.ebuild
index 542041ede4a8..d80d0c43e7eb 100644
--- a/x11-misc/xearth/xearth-1.1-r1.ebuild
+++ b/x11-misc/xearth/xearth-1.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -18,20 +18,23 @@ RDEPEND="
x11-libs/libX11
x11-libs/libXext
x11-libs/libXt"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
BDEPEND="
app-text/rman
- x11-base/xorg-proto
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1"
PATCHES=(
"${FILESDIR}"/${P}-include.patch
)
+
DOCS=( BUILT-IN GAMMA-TEST HISTORY README )
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}
src_compile() {