summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-10 22:16:05 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-10 22:16:22 +0200
commit56e0c700f0c0aa406e84d7dd300557c0eb3c4a3d (patch)
tree0a20601d84c3f1b7d808fb26c9b0a2cb41cf5486 /x11-misc/xfe/files
parentdev-libs/libmemcache: Masked for removal (diff)
downloadgentoo-56e0c700f0c0aa406e84d7dd300557c0eb3c4a3d.tar.gz
gentoo-56e0c700f0c0aa406e84d7dd300557c0eb3c4a3d.tar.bz2
gentoo-56e0c700f0c0aa406e84d7dd300557c0eb3c4a3d.zip
x11-misc/xfe: Use pkg-cofing to find freetype and xft.
Closes: https://bugs.gentoo.org/514800 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'x11-misc/xfe/files')
-rw-r--r--x11-misc/xfe/files/xfe-1.42-use_pkgconfig_for_freetype_and_xft.patch57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/xfe/files/xfe-1.42-use_pkgconfig_for_freetype_and_xft.patch b/x11-misc/xfe/files/xfe-1.42-use_pkgconfig_for_freetype_and_xft.patch
new file mode 100644
index 000000000000..1394f59abc2c
--- /dev/null
+++ b/x11-misc/xfe/files/xfe-1.42-use_pkgconfig_for_freetype_and_xft.patch
@@ -0,0 +1,57 @@
+--- xfe-1.42/configure.ac
++++ xfe-1.42/configure.ac
+@@ -29,6 +29,7 @@
+ AC_PROG_INSTALL
+ AC_PROG_LN_S
+ AC_PROG_MAKE_SET
++PKG_PROG_PKG_CONFIG
+
+
+ # Internationalization
+@@ -109,16 +110,13 @@
+
+ echo "checking whether FOX was compiled with Xft support... yes"
+
+- # Check for FreeType2 headers
+- freetype_config=''
+- AC_CHECK_PROGS(freetype_config,freetype-config,)
+- if test -n "$freetype_config"; then
+- freetype_cflags=`$freetype_config --cflags`
+- freetype_libs=`$freetype_config --libs`
+- LIBS="$LIBS $freetype_libs"
+- CPPFLAGS="$freetype_cflags $CPPFLAGS"
+- fi
+- AC_CHECK_HEADER(config/ftheader.h,,[AC_CHECK_HEADER(freetype/config/ftheader.h,,AC_MSG_ERROR("ftheader.h not found"))])
++ # Check for FreeType2
++ PKG_CHECK_MODULES(FREETYPE, freetype2, [
++ freetype_cflags="$FREETYPE_CFLAGS"
++ freetype_libs="$FREETYPE_LIBS"
++ LIBS="$LIBS $freetype_libs"
++ CPPFLAGS="$freetype_cflags $CPPFLAGS"
++ ], AC_MSG_ERROR("freetype not found"))
+
+ # Check for Xft headers
+ xft_config=''
+@@ -131,15 +129,13 @@
+ CXXFLAGS="${CXXFLAGS} -DHAVE_XFT_H"
+ else
+ # On some systems (e.g. Fedora) xft-config is deprecated and pkg-config should be used instead
+- pkg_config=''
+- AC_CHECK_PROGS(pkg_config,pkg-config,)
+- if test -n "$pkg_config"; then
+- xft_cflags=`$pkg_config --cflags xft`
+- xft_libs=`$pkg_config --libs xft`
+- LIBS="$LIBS $xft_libs"
+- CPPFLAGS="$xft_cflags $CPPFLAGS"
+- CXXFLAGS="${CXXFLAGS} -DHAVE_XFT_H"
+- fi
++ PKG_CHECK_MODULES(XFT, xft, [
++ xft_cflags="$XFT_CFLAGS"
++ xft_libs="$XFT_LIBS"
++ LIBS="$LIBS $xft_libs"
++ CPPFLAGS="$xft_cflags $CPPFLAGS"
++ CXXFLAGS="$CXXFLAGS -DHAVE_XFT_H"
++ ], AC_MSG_ERROR("Xft not found"))
+ fi
+ AC_CHECK_HEADER(X11/Xft/Xft.h,,AC_MSG_ERROR("Xft.h not found"))
+