summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-05-10 22:16:05 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-05-10 22:16:22 +0200
commit56e0c700f0c0aa406e84d7dd300557c0eb3c4a3d (patch)
tree0a20601d84c3f1b7d808fb26c9b0a2cb41cf5486 /x11-misc/xfe/xfe-1.42.ebuild
parentdev-libs/libmemcache: Masked for removal (diff)
downloadgentoo-56e0c700f0c0aa406e84d7dd300557c0eb3c4a3d.tar.gz
gentoo-56e0c700f0c0aa406e84d7dd300557c0eb3c4a3d.tar.bz2
gentoo-56e0c700f0c0aa406e84d7dd300557c0eb3c4a3d.zip
x11-misc/xfe: Use pkg-cofing to find freetype and xft.
Closes: https://bugs.gentoo.org/514800 Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'x11-misc/xfe/xfe-1.42.ebuild')
-rw-r--r--x11-misc/xfe/xfe-1.42.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/x11-misc/xfe/xfe-1.42.ebuild b/x11-misc/xfe/xfe-1.42.ebuild
index df2bd089efc3..dd6e5a79a2de 100644
--- a/x11-misc/xfe/xfe-1.42.ebuild
+++ b/x11-misc/xfe/xfe-1.42.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -36,6 +36,8 @@ DEPEND="
DOCS=( AUTHORS BUGS ChangeLog README TODO )
+PATCHES=( "${FILESDIR}/${PN}-1.42-use_pkgconfig_for_freetype_and_xft.patch" )
+
src_prepare() {
default
@@ -62,15 +64,15 @@ src_prepare() {
-e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' \
configure.ac || die
- eapply_user
-
eautoreconf
}
src_configure() {
- econf \
- $(use_enable debug) \
- $(use_enable nls) \
- $(use_enable startup-notification sn) \
+ local myeconfargs=(
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable startup-notification sn)
--enable-minimalflags
+ )
+ econf "${myeconfargs[@]}"
}