summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-10-21 20:15:58 -0700
committerMatt Turner <mattst88@gentoo.org>2021-10-21 21:32:15 -0700
commitd7a1136bdd39852721c4862e947451bcee5c0968 (patch)
treec838b5d657ca309402203ef612dc2ce9edc952d1 /x11-misc/xkeyboard-config
parentx11-misc/xkeyboard-config: Add Python 3.10 compatibility (diff)
downloadgentoo-d7a1136bdd39852721c4862e947451bcee5c0968.tar.gz
gentoo-d7a1136bdd39852721c4862e947451bcee5c0968.tar.bz2
gentoo-d7a1136bdd39852721c4862e947451bcee5c0968.zip
x11-misc/xkeyboard-config: Version bump to 2.34
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc/xkeyboard-config')
-rw-r--r--x11-misc/xkeyboard-config/Manifest1
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.34.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
index 96a3c0e60687..cf3f9dce3b7a 100644
--- a/x11-misc/xkeyboard-config/Manifest
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -1,2 +1,3 @@
DIST xkeyboard-config-2.32.tar.bz2 1742570 BLAKE2B 98374e1bbbeaf24268754df8f050c663f8d07cec770c8bb86cb11bc434f6463acc9221b75b8f5dec79c8e47ac9e77deeb919a8bd3377ba712aac1fe1ce64ccc8 SHA512 c082a86efcf69ab50454875686b9b4c388cf48002de3728331de3c09c1349a38c9b9ad8ecace2215061c0c775e59c3dd230fffe3f24db63790aa71dc8eff8dea
DIST xkeyboard-config-2.33.tar.bz2 1755990 BLAKE2B 63d5d789609711fb92acc69319efc64337cf512b3a47d3b8d24a9afbc5c57e45d6c1a7f4a283ae274b6534bb6667964248ef8dd320a24861a50580bfe2a29350 SHA512 084f79350d5dc7f9ebd5b5333d386459b0ab587f6cec27ee2d8d5c3a56b08993f9fafb9d893307f4d43cfeaf2e225c5295ad6297ae8287c68efc48a82638feb1
+DIST xkeyboard-config-2.34.tar.bz2 1763558 BLAKE2B 4417ab66f476de9914113296437b6a1b558c57561169353f533695bbe95831e73045c87bb3a072d1e3c103d2f69aedc3a73e5290c90ecaa8a131419d0d8ca3aa SHA512 cf3bdb658349b2db9db44ea1a0f7060b890b95520319101d83ba5aefeb0b1e2fd578b6f72a90758438f04bffbe7536cf112b76297fd47c95e02029fd203c51fb
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.34.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.34.ebuild
new file mode 100644
index 000000000000..9e1a13130f32
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.34.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..10} )
+inherit meson python-any-r1
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.x.org/releases/individual/data/${PN}/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ sys-devel/gettext
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dxkb-base="${EPREFIX}/usr/share/X11/xkb"
+ -Dcompat-rules=true
+ )
+ meson_src_configure
+}