summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-30 10:57:48 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-30 10:58:15 +0200
commitaf86d6604a1625b8caa74353b77a73e53095eafd (patch)
tree9c7f4ee189f23de93b9fa9d9020055714a2aba53 /x11-misc/xlockmore
parentx11-misc/evolvotron: Old (diff)
downloadgentoo-af86d6604a1625b8caa74353b77a73e53095eafd.tar.gz
gentoo-af86d6604a1625b8caa74353b77a73e53095eafd.tar.bz2
gentoo-af86d6604a1625b8caa74353b77a73e53095eafd.zip
x11-misc/xlockmore: Version 5.66_alpha08
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc/xlockmore')
-rw-r--r--x11-misc/xlockmore/Manifest1
-rw-r--r--x11-misc/xlockmore/xlockmore-5.66_alpha08.ebuild118
2 files changed, 119 insertions, 0 deletions
diff --git a/x11-misc/xlockmore/Manifest b/x11-misc/xlockmore/Manifest
index b8f61c89c921..9cc71065b339 100644
--- a/x11-misc/xlockmore/Manifest
+++ b/x11-misc/xlockmore/Manifest
@@ -2,3 +2,4 @@ DIST xlockmore-5.50.tar.xz 1632968 BLAKE2B 2e692d16d70e3186ec1f31c192414b286f881
DIST xlockmore-5.65.tar.xz 1945636 BLAKE2B d026975551e8ceafdcc7b8d8b6e404634f329d8d1f65e153b51798981103a023479dd58f2485c774aaf58f5928ea28a9f409c733ccfc75f98b65302e7e478ac5 SHA512 ecbf7e5c087843265eb4a537b3fe06a0d86d5f67d88c45137b6a7f4f5b30522d44fb87b5628cd9e042f90af129863fd3a4c2b5e2305df2dc3dfd867a03469ad8
DIST xlockmore-5.66ALPHA05.tar.xz 1945728 BLAKE2B df0d5a8b0122673204c30f416c4bb599476340f0a0a4a80e08efe42c77a5dfa2408d74375dfcf2d68740d0b2c0147faff8ee01fe96e106eeed14fc779bcb3344 SHA512 259a8b2b0e7f487e5bb025a8a6961c38933ae259b3544c66823e09ea2f0fc44e19155bd335870adca653c268dc4811d41570882b021977e4981f0ded36ce3909
DIST xlockmore-5.66ALPHA06.tar.xz 1947244 BLAKE2B 998d1438bc8ad95c21ebcace2e390936c56fe975331d2a82d10899a00b43fd245fc71c34050459d88fcc47c9b97bc074bd91be432df0a2933db0fd9153091888 SHA512 cd4d47a677b2e00f993b6a32cd2cd98a88fa04dca1d2a62303b58ebe2a4b26b4e4308a5c25883dbe8adade98ae85dbe7b61422ec05579a82b193eecb642b057c
+DIST xlockmore-5.66ALPHA08.tar.xz 1947004 BLAKE2B 44ad1f877d214a8b719db57df8f502391f635a4a9cd12bd470610c27543c4523acd6824cf01cb9bf6ca73628d4bc59bc25dafc436d4ee818d5590ae058a7b02d SHA512 a7bc5ffe09be91a5a903067c1e9cbdd5808207fc2ff0507e9bdfeb4156c187ee00da2a8d790a539b97e26985adb51326e1dcde9cdaa194bab4b8705117dc97ce
diff --git a/x11-misc/xlockmore/xlockmore-5.66_alpha08.ebuild b/x11-misc/xlockmore/xlockmore-5.66_alpha08.ebuild
new file mode 100644
index 000000000000..2bb52c63b8ed
--- /dev/null
+++ b/x11-misc/xlockmore/xlockmore-5.66_alpha08.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic pam
+
+DESCRIPTION="Just another screensaver application for X"
+HOMEPAGE="https://www.sillycycle.com/xlockmore.html"
+SRC_URI="
+ https://www.sillycycle.com/xlock/${P/_alpha/ALPHA}.tar.xz
+ https://www.sillycycle.com/xlock/recent-releases/${P/_alpha/ALPHA}.tar.xz
+"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt debug gtk imagemagick motif nas opengl pam truetype xinerama xlockrc vtlock"
+
+REQUIRED_USE="
+ || ( crypt pam )
+ pam? ( !xlockrc )
+ xlockrc? ( !pam )
+"
+RDEPEND="
+ gtk? ( x11-libs/gtk+:2 )
+ imagemagick? ( media-gfx/imagemagick:= )
+ motif? ( >=x11-libs/motif-2.3:0 )
+ nas? ( media-libs/nas )
+ opengl? (
+ virtual/opengl
+ virtual/glu
+ truetype? ( >=media-libs/ftgl-2.1.3_rc5 )
+ )
+ pam? ( sys-libs/pam )
+ truetype? ( media-libs/freetype:2 )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXpm
+ x11-libs/libXt
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-base/xorg-proto
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.46-freetype261.patch
+ "${FILESDIR}"/${PN}-5.47-CXX.patch
+ "${FILESDIR}"/${PN}-5.47-strip.patch
+ "${FILESDIR}"/${PN}-5.64_alpha0-LDFLAGS.patch
+)
+S=${WORKDIR}/${P/_alpha/ALPHA}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/XLOCKLIBPATHS="-L/d' \
+ -e '/XMLOCKLIBPATHS="-L/d' \
+ -e 's|/lib|'"${EPREFIX}/$(get_libdir)"'|g' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=()
+
+ if use opengl && use truetype; then
+ myconf=( --with-ftgl )
+ append-cppflags -DFTGL213
+ else
+ myconf=( --without-ftgl )
+ fi
+
+ myconf+=(
+ $(use_enable pam)
+ $(use_enable xlockrc)
+ $(use_enable vtlock)
+ $(use_with crypt)
+ $(use_with debug editres)
+ $(use_with gtk gtk2)
+ $(use_with imagemagick magick)
+ $(use_with motif)
+ $(use_with nas)
+ $(use_with opengl mesa)
+ $(use_with opengl)
+ $(use_with truetype freetype)
+ $(use_with truetype ttf)
+ $(use_with xinerama)
+ --disable-mb
+ --enable-appdefaultdir=/usr/share/X11/app-defaults
+ --enable-syslog
+ --enable-vtlock
+ --without-esound
+ --without-gtk
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ local DOCS=( README docs/{3d.howto,cell_automata,HACKERS.GUIDE,Purify,Revisions,TODO} )
+ default
+
+ pamd_mimic_system xlock auth
+
+ if use pam; then
+ fperms 755 /usr/bin/xlock
+ else
+ fperms 4755 /usr/bin/xlock
+ fi
+
+ docinto html
+ dodoc docs/xlock.html
+}