summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Todaro <solpeth@posteo.org>2020-07-30 09:22:02 +1000
committerSergei Trofimovich <slyfox@gentoo.org>2020-08-01 09:01:23 +0100
commit0294b282dcc4b2a44599070e48d4784776848796 (patch)
tree9d92600db04719d9c7762e6e9d47cd2dd9efb261 /x11-misc/xmobar
parentdev-haskell/libmpd: bump up to 0.9.1.0 (diff)
downloadgentoo-0294b282dcc4b2a44599070e48d4784776848796.tar.gz
gentoo-0294b282dcc4b2a44599070e48d4784776848796.tar.bz2
gentoo-0294b282dcc4b2a44599070e48d4784776848796.zip
x11-misc/xmobar: bump up to 0.35.1
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Jack Todaro <solpeth@posteo.org> Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'x11-misc/xmobar')
-rw-r--r--x11-misc/xmobar/Manifest1
-rw-r--r--x11-misc/xmobar/metadata.xml15
-rw-r--r--x11-misc/xmobar/xmobar-0.35.1.ebuild99
3 files changed, 112 insertions, 3 deletions
diff --git a/x11-misc/xmobar/Manifest b/x11-misc/xmobar/Manifest
index f8f176ea99ec..e67d06ea76c2 100644
--- a/x11-misc/xmobar/Manifest
+++ b/x11-misc/xmobar/Manifest
@@ -1 +1,2 @@
DIST xmobar-0.24.3.tar.gz 100317 BLAKE2B 3ca7aeb977688b975674dc767f645d15aaf296ff906f51d79529ee58d827188437695b4ee0b960563f6c0ce1489baf1f5bdc4360807989277078a93dfafb3ed1 SHA512 aa16d55b16cf108005ee8ec6c3d1b348b3e70a5182cbb97eed2aeb67bed83bee4b23acff6d29d5bda5a30ce35dc87463a6ade6e0814b588f53b173a1c3b5a5b3
+DIST xmobar-0.35.1.tar.gz 133251 BLAKE2B bebd535f2f29f89131b468e1226a63168321cfdb93129e4e3e6cdf9e2489bf4df6bdc02a5d3f6569d5c35d2cfe1fb05efec73587544c7526bf2f97bfe6a7e1b4 SHA512 fd7bb8710f3c877835aa0b20e0fca227f6f620c0be31acd46e6a464b4ba3f6c7da8df31cd3f345e606b03a54328dd9a298e46e8fc2935e74ebd8c5712cedbf76
diff --git a/x11-misc/xmobar/metadata.xml b/x11-misc/xmobar/metadata.xml
index 69dba3f2e452..3ecfd078e089 100644
--- a/x11-misc/xmobar/metadata.xml
+++ b/x11-misc/xmobar/metadata.xml
@@ -6,11 +6,20 @@
<name>Gentoo Haskell</name>
</maintainer>
<use>
+ <flag name="alsa">Use alsa-mixer to get the volume from soundcards</flag>
+ <flag name="conduit">Use conduit to fetch weather data.</flag>
+ <flag name="dbus">Publish a service on the session bus for controlling xmobar</flag>
+ <flag name="inotify">inotify support (modern Linux only). Required for the Mail and MBox plugins</flag>
<flag name="mpd">Support mpd plugin</flag>
- <flag name="mpris">Enables MPRIS v1, v2 support</flag>
<flag name="timezone">Enables localized date support</flag>
- <flag name="conduit">Use conduit to fetch weather data.</flag>
- <flag name="uvmeter">Plugin to show UV data for Australia.</flag>
+ <flag name="mpris">Enables MPRIS v1, v2 support</flag>
+ <flag name="rtsopts">Reduce process wakekups frequency to decrease CPU usage</flag>
+ <flag name="uvmeter">Plugin to show UV data for Australia</flag>
+ <flag name="weather">Enable weather plugin</flag>
+ <flag name="wifi">Wireless info support via nl80211. Required for the Wireless plugin on systems running Linux</flag>
+ <flag name="iwlib">Wireless info support via Wext ioctls (deprecated)</flag>
+ <flag name="xft">Use Xft to render text. UTF-8 support included</flag>
+ <flag name="xpm">Enable usage of xpm for icons</flag>
</use>
<longdescription>
Xmobar is a minimalistic text based status bar.
diff --git a/x11-misc/xmobar/xmobar-0.35.1.ebuild b/x11-misc/xmobar/xmobar-0.35.1.ebuild
new file mode 100644
index 000000000000..50130b0d928b
--- /dev/null
+++ b/x11-misc/xmobar/xmobar-0.35.1.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# ebuild generated by hackport 0.6.4.9999
+#hackport: flags: -all_extensions,+with_threaded,+with_utf8,with_iwlib:iwlib,with_alsa:alsa,with_xft:xft,with_datezone:timezone,with_dbus:dbus,with_mpd:mpd,with_inotify:inotify,with_mpris:mpris,with_xpm:xpm,with_nl80211:wifi
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A Minimalistic Text Based Status Bar"
+HOMEPAGE="http://xmobar.org"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa dbus inotify iwlib mpd mpris +rtsopts timezone uvmeter +weather wifi xft xpm"
+
+RDEPEND="dev-haskell/async:=[profile?]
+ >=dev-haskell/extensible-exceptions-0.1:=[profile?] <dev-haskell/extensible-exceptions-0.2:=[profile?]
+ >=dev-haskell/mtl-2.1:=[profile?] <dev-haskell/mtl-2.3:=[profile?]
+ dev-haskell/old-locale:=[profile?]
+ >=dev-haskell/parsec-3.1:=[profile?] <dev-haskell/parsec-3.2:=[profile?]
+ >=dev-haskell/parsec-numbers-0.1.0:=[profile?]
+ dev-haskell/regex-compat:=[profile?]
+ >=dev-haskell/stm-2.3:=[profile?] <dev-haskell/stm-2.6:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/x11-1.6.1:=[profile?]
+ >=dev-lang/ghc-8.4.3:=
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ alsa? ( >=dev-haskell/alsa-core-0.5:=[profile?] <dev-haskell/alsa-core-0.6:=[profile?]
+ >=dev-haskell/alsa-mixer-0.3:=[profile?] <dev-haskell/alsa-mixer-0.4:=[profile?] )
+ dbus? ( >=dev-haskell/dbus-1:=[profile?]
+ weather? ( dev-haskell/http-client-tls:=[profile?]
+ dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] )
+ xpm? ( x11-libs/libXpm ) )
+ !dbus? ( !uvmeter? ( weather? ( !xpm? ( dev-haskell/http-client-tls:=[profile?]
+ dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] ) ) ) )
+ inotify? ( >=dev-haskell/hinotify-0.3:=[profile?] <dev-haskell/hinotify-0.5:=[profile?] )
+ iwlib? ( >=dev-haskell/iwlib-0.1.0:=[profile?] <dev-haskell/iwlib-0.2:=[profile?]
+ net-wireless/wireless-tools )
+ !iwlib? ( wifi? ( >=dev-haskell/cereal-0.5.8.1:=[profile?]
+ >=dev-haskell/netlink-1.1.1.0:=[profile?] ) )
+ mpd? ( >=dev-haskell/libmpd-0.9.0.10:=[profile?] )
+ mpris? ( >=dev-haskell/dbus-1:=[profile?]
+ !dbus? ( !uvmeter? ( weather? ( dev-haskell/http-client-tls:=[profile?]
+ dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] ) ) )
+ xpm? ( x11-libs/libXpm
+ weather? ( dev-haskell/http-client-tls:=[profile?]
+ dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] ) )
+ !xpm? ( uvmeter? ( weather? ( dev-haskell/http-client-tls:=[profile?] ) ) ) )
+ !mpris? ( !dbus? ( weather? ( dev-haskell/http-client-tls:=[profile?] )
+ xpm? ( x11-libs/libXpm
+ weather? ( dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] ) ) ) )
+ timezone? ( >=dev-haskell/timezone-olson-0.1:=[profile?] <dev-haskell/timezone-olson-0.3:=[profile?]
+ >=dev-haskell/timezone-series-0.1:=[profile?] <dev-haskell/timezone-series-0.2:=[profile?] )
+ uvmeter? ( dev-haskell/http-conduit:=[profile?]
+ dev-haskell/http-types:=[profile?] )
+ xft? ( >=dev-haskell/x11-xft-0.2:=[profile?] <dev-haskell/x11-xft-0.4:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-2.2.0.1
+ test? ( >=dev-haskell/hspec-2 <dev-haskell/hspec-3
+ dev-haskell/temporary )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-all_extensions \
+ $(cabal_flag alsa with_alsa) \
+ $(cabal_flag timezone with_datezone) \
+ $(cabal_flag dbus with_dbus) \
+ $(cabal_flag inotify with_inotify) \
+ $(cabal_flag iwlib with_iwlib) \
+ $(cabal_flag mpd with_mpd) \
+ $(cabal_flag mpris with_mpris) \
+ $(cabal_flag wifi with_nl80211) \
+ $(cabal_flag rtsopts with_rtsopts) \
+ --flag=with_threaded \
+ --flag=with_utf8 \
+ $(cabal_flag uvmeter with_uvmeter) \
+ $(cabal_flag weather with_weather) \
+ $(cabal_flag xft with_xft) \
+ $(cabal_flag xpm with_xpm)
+}
+
+src_install() {
+ cabal_src_install
+
+ dodoc examples/xmobar.config examples/xmobar.hs readme.md changelog.md
+}