summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2015-09-16 05:53:54 +0200
committerJeroen Roovers <jer@gentoo.org>2015-09-16 05:53:54 +0200
commit9437bb82af886fca25543177bf8f96d6db51f306 (patch)
treef9fc09a5db7f60acf0464f18cc75c1e1d7452f7d /x11-misc/xnots/xnots-9999.ebuild
parentx11-misc/xvkbd: Version bump. (diff)
downloadgentoo-9437bb82af886fca25543177bf8f96d6db51f306.tar.gz
gentoo-9437bb82af886fca25543177bf8f96d6db51f306.tar.bz2
gentoo-9437bb82af886fca25543177bf8f96d6db51f306.zip
x11-misc/xnots: Live ebuild.
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-misc/xnots/xnots-9999.ebuild')
-rw-r--r--x11-misc/xnots/xnots-9999.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/x11-misc/xnots/xnots-9999.ebuild b/x11-misc/xnots/xnots-9999.ebuild
new file mode 100644
index 000000000000..d30b43eb9dc2
--- /dev/null
+++ b/x11-misc/xnots/xnots-9999.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="A desktop sticky note program for the unix geek"
+HOMEPAGE="http://xnots.sourceforge.net https://github.com/thePalindrome/xnots"
+EGIT_REPO_URI="https://github.com/thePalindrome/xnots"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="vim-syntax"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ x11-libs/libXrandr
+ x11-libs/pango[X]"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/renderproto
+ x11-proto/randrproto"
+
+src_prepare() {
+ sed -i -e 's|LICENCE||g' Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" NO_DEBUG=1
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ docdir=/usr/share/doc/${PF} \
+ mandir=/usr/share/man \
+ prefix=/usr \
+ install
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins etc/xnots.vim
+ fi
+}