summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-11-06 13:38:32 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-11-06 13:38:43 +0100
commit056e71b2a4d598195715eb5930a8ab92bd3f48aa (patch)
tree3d1062ad17ae68f691fbc666b8daea78231d9cc0 /x11-misc/xosview/xosview-1.20-r1.ebuild
parentkde-frameworks/kdelibs: Stable 4.14.37 (diff)
downloadgentoo-056e71b2a4d598195715eb5930a8ab92bd3f48aa.tar.gz
gentoo-056e71b2a4d598195715eb5930a8ab92bd3f48aa.tar.bz2
gentoo-056e71b2a4d598195715eb5930a8ab92bd3f48aa.zip
x11-misc/xosview: Revbump to install some more files.
Package-Manager: Portage-2.3.13, Repoman-2.3.4
Diffstat (limited to 'x11-misc/xosview/xosview-1.20-r1.ebuild')
-rw-r--r--x11-misc/xosview/xosview-1.20-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/xosview/xosview-1.20-r1.ebuild b/x11-misc/xosview/xosview-1.20-r1.ebuild
new file mode 100644
index 000000000000..f342c4311c82
--- /dev/null
+++ b/x11-misc/xosview/xosview-1.20-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs xdg-utils
+
+DESCRIPTION="X11 operating system viewer"
+HOMEPAGE="http://www.pogo.org.uk/~mark/xosview/"
+SRC_URI="http://www.pogo.org.uk/~mark/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="suid"
+
+COMMON_DEPS="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt"
+RDEPEND="${COMMON_DEPS}
+ media-fonts/font-misc-misc"
+DEPEND="${COMMON_DEPS}
+ x11-proto/xproto"
+
+DOCS=( CHANGES README.linux TODO )
+
+src_prepare() {
+ default
+
+ sed -i -e 's:lib/X11/app:share/X11/app:g' -i ${PN}.1 || die
+ sed -i -e "s:Git:${PV}:g" ${PN}.cc || die
+ tc-export CXX
+}
+
+src_compile() {
+ emake OPTFLAGS=''
+}
+
+src_install() {
+ emake PREFIX="${D%/}/usr" install
+ use suid && fperms 4755 /usr/bin/${PN}
+ insinto /usr/share/X11/app-defaults
+ newins Xdefaults XOsview
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ if ! use suid ; then
+ ewarn "If you want to use serial meters ${PN} needs to be executed as root."
+ ewarn "Please see ${EPREFIX}/usr/share/doc/${PF}/README.linux for details."
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}