summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2022-05-19 22:36:16 +0200
committerSam James <sam@gentoo.org>2022-05-20 02:16:26 +0100
commitaaabe6ee3dfa833a81675a67064c91cea9034f45 (patch)
treebc4016aad8f88cce118e89155769d28722b94515 /x11-misc/xpad
parentmedia-libs/fcft: add missing werror change (diff)
downloadgentoo-aaabe6ee3dfa833a81675a67064c91cea9034f45.tar.gz
gentoo-aaabe6ee3dfa833a81675a67064c91cea9034f45.tar.bz2
gentoo-aaabe6ee3dfa833a81675a67064c91cea9034f45.zip
x11-misc/xpad: add 5.8.0
Signed-off-by: Philipp Rösner <rndxelement@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/25563 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/xpad')
-rw-r--r--x11-misc/xpad/Manifest1
-rw-r--r--x11-misc/xpad/xpad-5.8.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/xpad/Manifest b/x11-misc/xpad/Manifest
index 8da6af7e465c..e3461617d1a4 100644
--- a/x11-misc/xpad/Manifest
+++ b/x11-misc/xpad/Manifest
@@ -1,2 +1,3 @@
DIST xpad-5.4.0.tar.bz2 163394 BLAKE2B 478e96b6c09748f4643d287887f8432642f42e6786e6473832328f7d1202a1a23d96f2a06859e8da096b0e6c420df06269b6c2459e67cbceb29b9f569d565931 SHA512 a20b1d16d0d9e4cb0b88c969165eb9514b69a0eaef91eca8a3fb4da08ea8a2db32891de3c8a2a4a97db21bf78f515c7b6f798c59ba155f480f866334fca7986f
DIST xpad-5.7.0.tar.bz2 162675 BLAKE2B 2166816696d2e00a261fcc8e9483841be7803121dc3669ab35fdd014728f16a47860448dd6b754836a3dfcd0fbbd1805b87e470f96c0b692fbe3a588c81ee35f SHA512 ab9319473cbec9a7022e520e2284853270fccca88ad19e8cb52024ce79a2dd8049251009a22b97e2387de12b9e75576e50d4d17a7236cb8e0eb4c840c3400ef3
+DIST xpad-5.8.0.tar.bz2 162732 BLAKE2B 6165e59b2d05e640f820f1f52811f214909f445adee4bfeb595fc3913493d15f4a25556b5edb006163a0c123b9953934c77cb519d0dd9f567170a0282637b43a SHA512 868dc820a172fc31f79fab5ee842e4f7e5646ae0239101bb442fc9a4a79b2c76052a70b635a9fa39fae22838df698a4a398188bc44dada63db16a756330c3cbd
diff --git a/x11-misc/xpad/xpad-5.8.0.ebuild b/x11-misc/xpad/xpad-5.8.0.ebuild
new file mode 100644
index 000000000000..91cad0d91599
--- /dev/null
+++ b/x11-misc/xpad/xpad-5.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg-utils
+
+DESCRIPTION="A sticky note application for GTK"
+HOMEPAGE="https://launchpad.net/xpad"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ dev-libs/atk
+ >=dev-libs/glib-2.58:2
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3[X]
+ x11-libs/gtksourceview:4
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND=">=dev-util/intltool-0.31
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}