summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilipp Rösner <rndxelement@protonmail.com>2022-03-18 23:24:52 +0100
committerJoonas Niilola <juippis@gentoo.org>2022-03-24 14:46:38 +0200
commite9ef2e179d50c144238ce30cb32de2b36f86a402 (patch)
tree5a9f8387951f88160e52f960f1f0a9130c877934 /x11-misc/xpad
parentkde-apps/parley: pkg_postinst optfeature re app-i18n/translate-shell (diff)
downloadgentoo-e9ef2e179d50c144238ce30cb32de2b36f86a402.tar.gz
gentoo-e9ef2e179d50c144238ce30cb32de2b36f86a402.tar.bz2
gentoo-e9ef2e179d50c144238ce30cb32de2b36f86a402.zip
x11-misc/xpad: version bump to 5.7
Added an build for x11-misc/xpad-5.7 with support for EAPI 8. Furthermore, I added myself as a proxied maintainer. Closes: https://bugs.gentoo.org/834946 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Philipp Rösner <rndxelement@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/24646 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc/xpad')
-rw-r--r--x11-misc/xpad/Manifest1
-rw-r--r--x11-misc/xpad/metadata.xml11
-rw-r--r--x11-misc/xpad/xpad-5.7.0.ebuild38
3 files changed, 48 insertions, 2 deletions
diff --git a/x11-misc/xpad/Manifest b/x11-misc/xpad/Manifest
index aa66759aaa15..8da6af7e465c 100644
--- a/x11-misc/xpad/Manifest
+++ b/x11-misc/xpad/Manifest
@@ -1 +1,2 @@
DIST xpad-5.4.0.tar.bz2 163394 BLAKE2B 478e96b6c09748f4643d287887f8432642f42e6786e6473832328f7d1202a1a23d96f2a06859e8da096b0e6c420df06269b6c2459e67cbceb29b9f569d565931 SHA512 a20b1d16d0d9e4cb0b88c969165eb9514b69a0eaef91eca8a3fb4da08ea8a2db32891de3c8a2a4a97db21bf78f515c7b6f798c59ba155f480f866334fca7986f
+DIST xpad-5.7.0.tar.bz2 162675 BLAKE2B 2166816696d2e00a261fcc8e9483841be7803121dc3669ab35fdd014728f16a47860448dd6b754836a3dfcd0fbbd1805b87e470f96c0b692fbe3a588c81ee35f SHA512 ab9319473cbec9a7022e520e2284853270fccca88ad19e8cb52024ce79a2dd8049251009a22b97e2387de12b9e75576e50d4d17a7236cb8e0eb4c840c3400ef3
diff --git a/x11-misc/xpad/metadata.xml b/x11-misc/xpad/metadata.xml
index 8f73356cc3dd..93bd8f933bed 100644
--- a/x11-misc/xpad/metadata.xml
+++ b/x11-misc/xpad/metadata.xml
@@ -1,9 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person" proxied="yes">
+ <email>rndxelement@protonmail.com</email>
+ <name>Philipp Rösner</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="launchpad">xpad</remote-id>
- <changelog>https://launchpadlibrarian.net/253130440/ChangeLog</changelog>
+ <changelog>https://launchpadlibrarian.net/589705902/ChangeLog</changelog>
</upstream>
</pkgmetadata>
diff --git a/x11-misc/xpad/xpad-5.7.0.ebuild b/x11-misc/xpad/xpad-5.7.0.ebuild
new file mode 100644
index 000000000000..86f88b038215
--- /dev/null
+++ b/x11-misc/xpad/xpad-5.7.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit autotools
+
+DESCRIPTION="A sticky note application for GTK"
+HOMEPAGE="https://launchpad.net/xpad"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk
+ dev-libs/atk
+ >=dev-libs/glib-2.58:2
+ sys-devel/gettext
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3[X]
+ x11-libs/gtksourceview:4
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/pango
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-util/intltool-0.31
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}