summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHarri Nieminen <moikkis@gmail.com>2017-02-05 15:32:46 +0200
committerDavid Seifert <soap@gentoo.org>2017-02-05 20:06:56 +0100
commitd37d3680c8cf9b457b6bf643a48ad135c2e3414d (patch)
tree1661ffe299f6060ede50b160ac3591e493e00a9c /x11-misc/xsensors/xsensors-0.70-r1.ebuild
parentx11-misc/driconf: Bump eapi, use newer python eclass, fix issues (diff)
downloadgentoo-d37d3680c8cf9b457b6bf643a48ad135c2e3414d.tar.gz
gentoo-d37d3680c8cf9b457b6bf643a48ad135c2e3414d.tar.bz2
gentoo-d37d3680c8cf9b457b6bf643a48ad135c2e3414d.zip
x11-misc/xsensors: EAPI bump 2 -> 6, rename configure.in to .ac
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3827
Diffstat (limited to 'x11-misc/xsensors/xsensors-0.70-r1.ebuild')
-rw-r--r--x11-misc/xsensors/xsensors-0.70-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/xsensors/xsensors-0.70-r1.ebuild b/x11-misc/xsensors/xsensors-0.70-r1.ebuild
new file mode 100644
index 000000000000..f66b915a5049
--- /dev/null
+++ b/x11-misc/xsensors/xsensors-0.70-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A hardware health information viewer, interface to lm-sensors"
+HOMEPAGE="http://www.linuxhardware.org/xsensors/"
+SRC_URI="http://www.linuxhardware.org/xsensors/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=sys-apps/lm_sensors-3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gtk220.patch )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/-DG.*_DISABLE_DEPRECATED/d' \
+ -e 's:-Werror:-Wall:' \
+ src/Makefile.am configure.in || die
+
+ mv configure.{in,ac} || die #426262
+
+ eautoreconf
+}