summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKhue Nguyen <Z5483Y@gmail.com>2021-08-22 18:54:49 -0400
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-08-24 11:29:47 -0700
commita5c5040ed8473d32622df88da1818e58aae05ee6 (patch)
tree77b56c7b2421221c4f2b0a68812c9f2e0dd617c5 /x11-misc/xwallpaper/xwallpaper-0.7.3.ebuild
parentdev-python/flask-babelex: enable py3.10, cleanup python_test (diff)
downloadgentoo-a5c5040ed8473d32622df88da1818e58aae05ee6.tar.gz
gentoo-a5c5040ed8473d32622df88da1818e58aae05ee6.tar.bz2
gentoo-a5c5040ed8473d32622df88da1818e58aae05ee6.zip
x11-misc/xwallpaper: bump to 0.7.3
Package-Manager: Portage-3.0.22, Repoman-3.0.3 Signed-off-by: Khue Nguyen <Z5483Y@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/22074 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'x11-misc/xwallpaper/xwallpaper-0.7.3.ebuild')
-rw-r--r--x11-misc/xwallpaper/xwallpaper-0.7.3.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/x11-misc/xwallpaper/xwallpaper-0.7.3.ebuild b/x11-misc/xwallpaper/xwallpaper-0.7.3.ebuild
new file mode 100644
index 000000000000..548fe3496699
--- /dev/null
+++ b/x11-misc/xwallpaper/xwallpaper-0.7.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Wallpaper setting utility for X"
+HOMEPAGE="https://github.com/stoeckmann/xwallpaper"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/stoeckmann/${PN}.git"
+else
+ SRC_URI="https://github.com/stoeckmann/${PN}/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="+jpeg +png seccomp xpm"
+
+RDEPEND="
+ x11-libs/pixman
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ png? ( media-libs/libpng:0= )
+ seccomp? ( >=sys-libs/libseccomp-2.3.1:0= )
+ xpm? ( x11-libs/libXpm )
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with seccomp)
+ $(use_with xpm)
+ --with-randr
+ )
+ econf "${myconf[@]}"
+}