summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-09-16 13:32:28 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-09-16 13:32:41 +0200
commit00e332391cfd9292b18267a77e5ca1746e16b096 (patch)
treeebabd4cc16be8f162921d9f5f9ca91f2c1d4803b /x11-misc
parentwww-servers/tomcat: bump to 9.0.38 (diff)
downloadgentoo-00e332391cfd9292b18267a77e5ca1746e16b096.tar.gz
gentoo-00e332391cfd9292b18267a77e5ca1746e16b096.tar.bz2
gentoo-00e332391cfd9292b18267a77e5ca1746e16b096.zip
x11-misc/picom: 8.1 bump
Closes: https://bugs.gentoo.org/742386 Package-Manager: Portage-3.0.7, Repoman-3.0.1 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/picom/Manifest1
-rw-r--r--x11-misc/picom/picom-8.1.ebuild60
-rw-r--r--x11-misc/picom/picom-9999.ebuild1
3 files changed, 61 insertions, 1 deletions
diff --git a/x11-misc/picom/Manifest b/x11-misc/picom/Manifest
index 4d1db30768fb..8ef3f773a272 100644
--- a/x11-misc/picom/Manifest
+++ b/x11-misc/picom/Manifest
@@ -1,2 +1,3 @@
DIST picom-7.5.tar.gz 219456 BLAKE2B 54113547b575ad6aa1329e92ae331b7d49207fdcdc6b49d31d8ab125f7335730a7e53b260c6a6c33d5350bec1e9e6357fd34023dc7837de165289446f8f492b8 SHA512 6535e5eab1a243bbee62448bc48830b7ea3566f94b2c45d9ca76fd8b8056e1f00e55f0e4b58110364d2c4f56652cc005622d644c1db1db41d2811ecc19e6d44a
+DIST picom-8.1.tar.gz 242262 BLAKE2B 69583a7a188f62387f0784e33acfc3d84e6b7b1987f44f7634b1bd2244ae8e8763c2131a824f8ddd748558002a876cb359c656a93fcb55ad33a24cca2b7dc56e SHA512 d1d0428e5761db6820c775c07b966b5fec6a9e9d049ba9f555eb49721f855a018df7242ef61e29c0ea003644b20e1bb733ddf668053a8d4040240e98707fa4d3
DIST picom-8.tar.gz 242059 BLAKE2B cfeec7f40eaa43c115bd326abeaa547553f7bdd22a2e6b2a96f46d87c164b0e9403a876f069077e3b85d11af685aadb0cff2a4e7df2cf87646f2552f9c1a01df SHA512 154dd42dea16aca463e7d7f9913a8f10740df892bfdda2fee210a94b13c8eaf6201b35e505daf45075fdb1980bb9b85adf170b649702c1b1e2fcdc1d88406b4a
diff --git a/x11-misc/picom/picom-8.1.ebuild b/x11-misc/picom/picom-8.1.ebuild
new file mode 100644
index 000000000000..993b85a8ab0f
--- /dev/null
+++ b/x11-misc/picom/picom-8.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8,9} )
+inherit meson python-any-r1 virtualx xdg
+
+DESCRIPTION="A lightweight compositor for X11 (previously a compton fork)"
+HOMEPAGE="https://github.com/yshui/picom"
+SRC_URI="https://github.com/yshui/picom/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="+config-file dbus +doc +drm opengl pcre test"
+
+REQUIRED_USE="test? ( dbus )" # avoid "DBus support not compiled in!"
+RESTRICT="test" # but tests require dbus_next
+
+RDEPEND="
+ dev-libs/libev
+ dev-libs/uthash
+ x11-libs/libX11
+ x11-libs/libxcb
+ x11-libs/libXext
+ x11-libs/pixman
+ x11-libs/xcb-util-image
+ x11-libs/xcb-util-renderutil
+ config-file? (
+ dev-libs/libconfig
+ dev-libs/libxdg-basedir
+ )
+ dbus? ( sys-apps/dbus )
+ drm? ( x11-libs/libdrm )
+ opengl? ( virtual/opengl )
+ pcre? ( dev-libs/libpcre )
+ !x11-misc/compton"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-text/asciidoc )
+ test? ( $(python_gen_any_dep 'dev-python/xcffib[${PYTHON_USEDEP}]') )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use config-file config_file)
+ $(meson_use dbus)
+ $(meson_use doc with_docs)
+ $(meson_use opengl)
+ $(meson_use pcre regex)
+ )
+
+ meson_src_configure
+}
+
+src_test() {
+ virtx "${S}/tests/run_tests.sh" "${BUILD_DIR}/src/${PN}"
+}
diff --git a/x11-misc/picom/picom-9999.ebuild b/x11-misc/picom/picom-9999.ebuild
index 34d4a6e2fb59..8d71941fd1a6 100644
--- a/x11-misc/picom/picom-9999.ebuild
+++ b/x11-misc/picom/picom-9999.ebuild
@@ -46,5 +46,4 @@ src_configure() {
)
meson_src_configure
-
}