summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <sudinave@gmail.com>2021-04-14 08:36:30 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-04-15 09:38:56 +0300
commit0165a108c3dc2a6881c0610d47b887695064091a (patch)
tree9d19795cffbfb11dbdee78b7d97c4791ef47a0e0 /x11-misc
parentx11-misc/xbatt: fix build with -native-symlinks (diff)
downloadgentoo-0165a108c3dc2a6881c0610d47b887695064091a.tar.gz
gentoo-0165a108c3dc2a6881c0610d47b887695064091a.tar.bz2
gentoo-0165a108c3dc2a6881c0610d47b887695064091a.zip
x11-misc/xcalendar: fix build with -native-symlinks
Closes: https://bugs.gentoo.org/726258 Signed-off-by: Ionen Wolkens <sudinave@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xcalendar/xcalendar-4.0-r2.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/x11-misc/xcalendar/xcalendar-4.0-r2.ebuild b/x11-misc/xcalendar/xcalendar-4.0-r2.ebuild
index b89bdea80b70..a6ccd1896657 100644
--- a/x11-misc/xcalendar/xcalendar-4.0-r2.ebuild
+++ b/x11-misc/xcalendar/xcalendar-4.0-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -20,7 +20,7 @@ RDEPEND="x11-libs/libX11
x11-libs/libXext"
DEPEND="${RDEPEND}
x11-base/xorg-proto
- x11-misc/imake
+ >=x11-misc/imake-1.0.8-r1
x11-misc/gccmakedep
motif? ( >=x11-libs/motif-2.3:0 )"
@@ -35,9 +35,16 @@ src_prepare() {
-i XCalendar.sed || die
}
+src_configure() {
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf -a || die
+}
+
src_compile() {
- xmkmf -a || die
- emake CC="$(tc-getCC)" CDEBUGFLAGS="${CFLAGS}" EXTRA_LDOPTIONS="${LDFLAGS}"
+ emake \
+ CC="$(tc-getCC)" \
+ CDEBUGFLAGS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
}
src_install() {