summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 09:20:08 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:12 +0100
commit05449c4740c85971201fb366bcb50820a6547536 (patch)
tree4fb95ed3fc4c3d211629792114c6f5cd90a8a178 /x11-misc
parentx11-misc/devilspie2: respect PKG_CONFIG (diff)
downloadgentoo-05449c4740c85971201fb366bcb50820a6547536.tar.gz
gentoo-05449c4740c85971201fb366bcb50820a6547536.tar.bz2
gentoo-05449c4740c85971201fb366bcb50820a6547536.zip
x11-misc/grabc: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/grabc/files/grabc-1.1-makefile.patch6
-rw-r--r--x11-misc/grabc/grabc-1.1-r2.ebuild9
2 files changed, 9 insertions, 6 deletions
diff --git a/x11-misc/grabc/files/grabc-1.1-makefile.patch b/x11-misc/grabc/files/grabc-1.1-makefile.patch
index 4815ae5675c5..ef2968ba0e14 100644
--- a/x11-misc/grabc/files/grabc-1.1-makefile.patch
+++ b/x11-misc/grabc/files/grabc-1.1-makefile.patch
@@ -1,5 +1,5 @@
---- grabc1.1/Makefile.org 1997-03-17 06:51:39.000000000 +0100
-+++ grabc1.1/Makefile 2010-02-08 12:18:34.000000000 +0100
+--- a/Makefile
++++ b/Makefile
@@ -2,17 +2,15 @@
# Makefile automatically generated by genmake 1.0, Mar-16-97
# genmake 1.0 by ma_muquit@fccc.edu, RCS
@@ -8,7 +8,7 @@
DEFS=
PROGNAME= grabc
-LIBS= -L/usr/X11R6/lib -lX11
-+LIBS= $(shell pkg-config --libs x11)
++LIBS= $(shell ${PKG_CONFIG} --libs x11)
INCLUDES= -I.
diff --git a/x11-misc/grabc/grabc-1.1-r2.ebuild b/x11-misc/grabc/grabc-1.1-r2.ebuild
index 236e8510f814..847aacb19a8d 100644
--- a/x11-misc/grabc/grabc-1.1-r2.ebuild
+++ b/x11-misc/grabc/grabc-1.1-r2.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+
inherit toolchain-funcs
DESCRIPTION="Identify color of a pixel on the screen by clicking on a pixel on the screen"
@@ -15,13 +16,15 @@ IUSE=""
RDEPEND="x11-libs/libX11"
DEPEND="${RDEPEND}
- x11-base/xorg-proto"
+ x11-base/xorg-proto
+ virtual/pkgconfig
+"
S="${WORKDIR}/${PN}${PV}"
PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
src_compile() {
- tc-export CC
+ tc-export CC PKG_CONFIG
default
}