summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-05-05 09:41:31 +0200
committerJeroen Roovers <jer@gentoo.org>2016-05-05 09:41:31 +0200
commit0627a842e6afa42b0972ee4dd9180acdbc1798e1 (patch)
tree94f39cc961eadc0add3050cfd1da8cec1a1b097c /x11-misc
parentnet-misc/youtube-dl: Version bump. (diff)
downloadgentoo-0627a842e6afa42b0972ee4dd9180acdbc1798e1.tar.gz
gentoo-0627a842e6afa42b0972ee4dd9180acdbc1798e1.tar.bz2
gentoo-0627a842e6afa42b0972ee4dd9180acdbc1798e1.zip
x11-misc/rofi: Version bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/rofi/Manifest1
-rw-r--r--x11-misc/rofi/rofi-1.0.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/x11-misc/rofi/Manifest b/x11-misc/rofi/Manifest
index 506fac46bed2..a69f2b609e2b 100644
--- a/x11-misc/rofi/Manifest
+++ b/x11-misc/rofi/Manifest
@@ -1,2 +1,3 @@
DIST rofi-0.15.12.tar.xz 143260 SHA256 e942d865add1bf70423c536583945fcefa9fc45b17c3f222bc3cb56c692ddeed SHA512 23667e949395e87a33105d231a3894db0a159edb8126a49254cd6f6d0c4bf8577d9209af709e05d2e451d6d53a937cf56cd2be58e9c85f8dd2615232fc29b1b0 WHIRLPOOL 783b29c30e31db16bc43fe531301ce6d8c5917275a5085210887f45371bf0a851ff57257df6e7d3ad5f64a4412c950eec1499065a79ad796dcb4d8939547f048
DIST rofi-1.0.0.tar.xz 184152 SHA256 a50a4cd76b90e6987451594dc3323dc01920faf18e22f54a756afa276f492d2b SHA512 c415b0f2b5e97d1e3a4c4ae262dc61d5c5c50df976aa65c81f5ab7af84b8e88578ef7b670b87b873a2f0d71b638ec57147f6233488f3114365c122d04aee38e1 WHIRLPOOL 751ff5d315538838dface0c07b6c920ff7f03646f059fe05f5a995e7ddb6cd8890f785aa1771b0f5a48be83d59f2c66c545689de25034997bd7374307a257ab5
+DIST rofi-1.0.1.tar.xz 183700 SHA256 6718508cef6fc1c1e91000380357341aa5556f6cc7aafbec3d9c91b913ad5d06 SHA512 18001ae084e6148d91a1cb6176d44af3d916e24a11abbfdcf7104f8c9909b8172420a271760322b8354b6790e720f819ba75c3df13f011ed4cb280d0e65ef618 WHIRLPOOL a04ecc0ff45f701c3035aef2eecc7f75c08aff5cbcb3b494cb5bf7d30aac93dfb8b6e86c87e36eacd5752f176a580bebfd19193377a59c8bf47c8cc67263b1f9
diff --git a/x11-misc/rofi/rofi-1.0.1.ebuild b/x11-misc/rofi/rofi-1.0.1.ebuild
new file mode 100644
index 000000000000..0b3da2187b75
--- /dev/null
+++ b/x11-misc/rofi/rofi-1.0.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils toolchain-funcs
+
+DESCRIPTION="A window switcher, run dialog and dmenu replacement"
+HOMEPAGE="https://davedavenport.github.io/rofi/"
+SRC_URI="https://github.com/DaveDavenport/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="i3 windowmode"
+REQUIRED_USE="i3? ( windowmode )"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/freetype
+ x11-libs/cairo[xcb]
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXinerama
+ x11-libs/libxcb
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ i3? ( x11-wm/i3 )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xineramaproto
+ x11-proto/xproto
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.15.12-Werror.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable windowmode) \
+ $(usex i3 '' --disable-i3support)
+}
+
+src_test() {
+ emake test
+}