summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-25 11:35:25 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-25 11:48:07 +0100
commit09411e9512455df329ebd9fee8d1fd1b709d124e (patch)
tree57c6f8b064d0b934ccc7c4ceabb9e5ee78676a1c /x11-misc
parentnet-analyzer/wireshark: Drop upstream patch (diff)
downloadgentoo-09411e9512455df329ebd9fee8d1fd1b709d124e.tar.gz
gentoo-09411e9512455df329ebd9fee8d1fd1b709d124e.tar.bz2
gentoo-09411e9512455df329ebd9fee8d1fd1b709d124e.zip
x11-misc/i3lock: Fix compiling with -fno-common
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Closes: https://bugs.gentoo.org/706286 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/i3lock/files/i3lock-2.12-fno-common.patch11
-rw-r--r--x11-misc/i3lock/i3lock-2.12-r2.ebuild47
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/i3lock/files/i3lock-2.12-fno-common.patch b/x11-misc/i3lock/files/i3lock-2.12-fno-common.patch
new file mode 100644
index 000000000000..09003b165919
--- /dev/null
+++ b/x11-misc/i3lock/files/i3lock-2.12-fno-common.patch
@@ -0,0 +1,11 @@
+--- a/unlock_indicator.c
++++ b/unlock_indicator.c
+@@ -35,7 +35,7 @@
+
+ /* The current position in the input buffer. Useful to determine if any
+ * characters of the password have already been entered or not. */
+-int input_position;
++extern int input_position;
+
+ /* The lock window. */
+ extern xcb_window_t win;
diff --git a/x11-misc/i3lock/i3lock-2.12-r2.ebuild b/x11-misc/i3lock/i3lock-2.12-r2.ebuild
new file mode 100644
index 000000000000..07a68eb55c25
--- /dev/null
+++ b/x11-misc/i3lock/i3lock-2.12-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Simple screen locker"
+HOMEPAGE="https://i3wm.org/i3lock/"
+SRC_URI="https://i3wm.org/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=x11-libs/libxkbcommon-0.5.0[X]
+ dev-libs/libev
+ sys-libs/pam
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/libxcb[xkb]
+ x11-libs/xcb-util
+ x11-libs/xcb-util-xrm
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+DOCS=( CHANGELOG README.md )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.12-fno-common.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's:login:system-auth:g' pam/${PN} || die
+}
+
+src_configure() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ default
+ doman ${PN}.1
+}