summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2021-07-29 08:52:09 -0500
committerBen Kohler <bkohler@gentoo.org>2021-07-29 08:53:01 -0500
commit0fa93f12b224b1bfb4a0252713c276c69b25c034 (patch)
treeb57c214860be992427d5896ddf2c489786c4d14a /x11-misc
parentnet-libs/mbedtls: [QA] fix subslot (diff)
downloadgentoo-0fa93f12b224b1bfb4a0252713c276c69b25c034.tar.gz
gentoo-0fa93f12b224b1bfb4a0252713c276c69b25c034.tar.bz2
gentoo-0fa93f12b224b1bfb4a0252713c276c69b25c034.zip
x11-misc/bbcd: fix gcc11 build
Closes: https://bugs.gentoo.org/787098 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/bbcd/bbcd-0.3.1-r3.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/x11-misc/bbcd/bbcd-0.3.1-r3.ebuild b/x11-misc/bbcd/bbcd-0.3.1-r3.ebuild
index 23c67dd2c16c..ee2e46b6956b 100644
--- a/x11-misc/bbcd/bbcd-0.3.1-r3.ebuild
+++ b/x11-misc/bbcd/bbcd-0.3.1-r3.ebuild
@@ -3,6 +3,8 @@
EAPI=6
+inherit flag-o-matic
+
DESCRIPTION="Basic CD Player for blackbox wm"
HOMEPAGE="http://tranber1.free.fr/bbcd.html"
SRC_URI="http://tranber1.free.fr/${P}.tar.gz"
@@ -23,6 +25,11 @@ PATCHES=(
"${FILESDIR}"/${P}-gcc4.3.patch
)
+src_configure() {
+ append-cxxflags -std=c++14
+ default
+}
+
src_install() {
default
rm "${ED%/}"/usr/share/bbtools/README.bbcd || die