summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-03-28 18:32:05 +1100
committerSam Jorna <wraeth@gentoo.org>2016-03-28 18:32:39 +1100
commit3c3d1cc6567130ca788e17b9b02daa268f46e52e (patch)
treeba6c5dfd5b1e7923a0195c3599b2bf8af3bf91dd /x11-misc
parentapp-arch/p7zip: fix compilation on OSX El Capitan also, bug #577344 (diff)
downloadgentoo-3c3d1cc6567130ca788e17b9b02daa268f46e52e.tar.gz
gentoo-3c3d1cc6567130ca788e17b9b02daa268f46e52e.tar.bz2
gentoo-3c3d1cc6567130ca788e17b9b02daa268f46e52e.zip
x11-misc/matchbox-keyboard: fix .desktop qa warn
Patches desktop file to resolve QA warning, bump to EAPI6. Ebuild and patch from user popham to resolve bug. Gentoo-bug: 434704 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/matchbox-keyboard/files/matchbox-keyboard-0.1-r1-modernize_desktop.patch11
-rw-r--r--x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild28
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/matchbox-keyboard/files/matchbox-keyboard-0.1-r1-modernize_desktop.patch b/x11-misc/matchbox-keyboard/files/matchbox-keyboard-0.1-r1-modernize_desktop.patch
new file mode 100644
index 000000000000..6ead1a4c0293
--- /dev/null
+++ b/x11-misc/matchbox-keyboard/files/matchbox-keyboard-0.1-r1-modernize_desktop.patch
@@ -0,0 +1,11 @@
+--- a/matchbox-keyboard.desktop
++++ b/matchbox-keyboard.desktop
+@@ -3,6 +3,6 @@
+ Comment=Virtual Keyboard
+ Exec=matchbox-keyboard
+ Type=Application
+-Icon=matchbox-keyboard.png
+-Categories=Panel;Utility;MB
++Icon=matchbox-keyboard
++Categories=Utility;X-MB;X-Panel;
+ X-MB-INPUT-MECHANSIM=True
diff --git a/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild
new file mode 100644
index 000000000000..ceaa915e5f7c
--- /dev/null
+++ b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+inherit versionator eutils
+
+DESCRIPTION="Matchbox-keyboard is an on screen 'virtual' or 'software' keyboard"
+HOMEPAGE="http://matchbox-project.org/"
+SRC_URI="http://matchbox-project.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86"
+IUSE="debug cairo"
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README )
+PATCHES=( "${FILESDIR}"/${PN}-0.1-r1-modernize_desktop.patch )
+
+DEPEND="x11-libs/libfakekey
+ cairo? ( x11-libs/cairo[X] )
+ !cairo? ( x11-libs/libXft )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ econf $(use_enable debug) $(use_enable cairo)
+}