summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-09-15 22:19:15 +0200
committerJeroen Roovers <jer@gentoo.org>2020-09-15 22:20:34 +0200
commit4327eadd31cbeca4aaa05c033a62ba3a7baac053 (patch)
tree893961f90e0e77b84811a90e66ae52633eeb36e0 /x11-misc
parentprofiles/package.mask: strip trailing whitespace in older masks (diff)
downloadgentoo-4327eadd31cbeca4aaa05c033a62ba3a7baac053.tar.gz
gentoo-4327eadd31cbeca4aaa05c033a62ba3a7baac053.tar.bz2
gentoo-4327eadd31cbeca4aaa05c033a62ba3a7baac053.zip
x11-misc/evolvotron: Depend on dev-qt/qtwidgets:5, drop old HOMEPAGE
Package-Manager: Portage-3.0.7, Repoman-3.0.1 Closes: https://bugs.gentoo.org/724630 Closes: https://bugs.gentoo.org/742692 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild54
-rw-r--r--x11-misc/evolvotron/evolvotron-0.7.1.ebuild3
2 files changed, 56 insertions, 1 deletions
diff --git a/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild b/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..c8f3df726e12
--- /dev/null
+++ b/x11-misc/evolvotron/evolvotron-0.7.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit qmake-utils
+
+DESCRIPTION="Generative art image evolver"
+HOMEPAGE="
+ https://sourceforge.net/projects/evolvotron/
+"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtxml:5
+"
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ BUGS NEWS README TODO USAGE
+)
+HTML_DOCS=(
+ evolvotron.html
+)
+S=${WORKDIR}/${PN}
+
+src_configure() {
+ eqmake5 main.pro
+}
+
+src_compile() {
+ local etsubdir
+ for etsubdir in \
+ libfunction libevolvotron evolvotron evolvotron_render evolvotron_mutate
+ do
+ emake sub-${etsubdir}
+ done
+}
+
+src_install() {
+ local bin
+ for bin in ${PN}{,_mutate,_render}; do
+ dobin ${bin}/${bin}
+ done
+ doman man/man1/*
+ einstalldocs
+}
diff --git a/x11-misc/evolvotron/evolvotron-0.7.1.ebuild b/x11-misc/evolvotron/evolvotron-0.7.1.ebuild
index dd964488f2e3..62f289f61def 100644
--- a/x11-misc/evolvotron/evolvotron-0.7.1.ebuild
+++ b/x11-misc/evolvotron/evolvotron-0.7.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -19,6 +19,7 @@ RDEPEND="
dev-libs/boost:=
dev-qt/qtcore:5
dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
dev-qt/qtxml:5
"
DEPEND="${RDEPEND}"