summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-04-16 14:35:21 +0200
committerDavid Seifert <soap@gentoo.org>2023-04-16 14:35:21 +0200
commit4b158a403c47d75292d34506f48cbfaaef3f574f (patch)
tree0cd7377483e91e1853f789a8d69355c53aec9a66 /x11-misc
parentsci-biology/biopython: drop 1.79 (diff)
downloadgentoo-4b158a403c47d75292d34506f48cbfaaef3f574f.tar.gz
gentoo-4b158a403c47d75292d34506f48cbfaaef3f574f.tar.bz2
gentoo-4b158a403c47d75292d34506f48cbfaaef3f574f.zip
x11-misc/xcape: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xcape/files/xcape-1.2-makefile.patch27
-rw-r--r--x11-misc/xcape/xcape-1.2-r1.ebuild26
-rw-r--r--x11-misc/xcape/xcape-1.2.ebuild37
3 files changed, 53 insertions, 37 deletions
diff --git a/x11-misc/xcape/files/xcape-1.2-makefile.patch b/x11-misc/xcape/files/xcape-1.2-makefile.patch
new file mode 100644
index 000000000000..06d4d04cdf50
--- /dev/null
+++ b/x11-misc/xcape/files/xcape-1.2-makefile.patch
@@ -0,0 +1,27 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,19 +1,16 @@
+ INSTALL=install
+-PREFIX=/usr
+-MANDIR?=/local/man/man1
++PREFIX=$(EPREFIX)/usr
++MANDIR?=/share/man/man1
+
+ TARGET := xcape
+
+ CFLAGS += -Wall
+-CFLAGS += `pkg-config --cflags xtst x11`
+-LDFLAGS += `pkg-config --libs xtst x11`
+-LDFLAGS += -pthread
++CFLAGS += `$(PKG_CONFIG) --cflags xtst x11`
++LDLIBS += `$(PKG_CONFIG) --libs xtst x11`
++LDLIBS += -pthread
+
+ all: $(TARGET)
+
+-$(TARGET): xcape.c
+- $(CC) $(CFLAGS) -o $@ $< $(LDFLAGS)
+-
+ install:
+ $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)/bin
+ $(INSTALL) -d -m 0755 $(DESTDIR)$(PREFIX)$(MANDIR)
diff --git a/x11-misc/xcape/xcape-1.2-r1.ebuild b/x11-misc/xcape/xcape-1.2-r1.ebuild
new file mode 100644
index 000000000000..8b524c8c6a55
--- /dev/null
+++ b/x11-misc/xcape/xcape-1.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility to make modifier keys send custom key events when pressed on their own"
+HOMEPAGE="https://github.com/alols/xcape"
+SRC_URI="https://github.com/alols/xcape/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libXtst"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+}
diff --git a/x11-misc/xcape/xcape-1.2.ebuild b/x11-misc/xcape/xcape-1.2.ebuild
deleted file mode 100644
index 48e5ae1a3290..000000000000
--- a/x11-misc/xcape/xcape-1.2.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Utility to make modifier keys send custom key events when pressed on their own"
-HOMEPAGE="https://github.com/alols/xcape"
-SRC_URI="https://github.com/alols/xcape/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="x11-libs/libX11
- x11-libs/libXtst"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
-
-src_prepare() {
- default
-
- # Fix path to man and to pkg-config
- sed -i \
- -e '/MANDIR/s:local:share:' \
- -e 's/pkg-config/${PKG_CONFIG}/' \
- Makefile || die
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" PKG_CONFIG="$(tc-getPKG_CONFIG)"
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
-}